Thunderbird hang if firefox is open (last Ubuntu updates) + USERS profile in network share Samba 4

RESOLVED WORKSFORME

Status

MailNews Core
Networking
--
critical
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: Miguel, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.94 Safari/537.36

Steps to reproduce:

Note: All the files off the user arte store in the server

Open thunderbird let it run
Open Firefox and browse the web for some time
Go to thunderbird and try to received or send messages.



Actual results:

It completly gray out and even after 1h it says in that freeze. Have to reboot the workstation to it starts working again


Expected results:

This only star appening now with the recent buids. If I use chrome I can run thunderbird all day (like it use to be before)
(Reporter)

Updated

3 years ago
Severity: normal → major

Comment 1

3 years ago
This sounds quite odd.  I don't see how Firefox should affect things.
Severity: major → critical
Keywords: hang
Summary: Thunderbird crash if firefoz is open (last Ubuntu updates) + USERS in Samba 4 → Thunderbird crash if firefox is open (last Ubuntu updates) + USERS profile in network share Samba 4
(Reporter)

Comment 2

3 years ago
I really don't know that to. We have 7 workstations, and this appends in all of them. The instalations are similar, and the addons to:
Firefox: Ghostery+Better rpyvacy+https everywhere + add block
Thunderbird: Lightning + And the Offcie 2003 theme

Only with this new updtaes this starts. If I use a local user this don't occur. 

If you need some more info please let me know

Comment 3

3 years ago
Does it happen if Firefox and Thunderbird are started in safe mode?
Flags: needinfo?(xadrezmiguelpires)
(Reporter)

Comment 4

3 years ago
I've to test that. I only test Thunderbird and it freezes.
Flags: needinfo?(xadrezmiguelpires)

Updated

3 years ago
Summary: Thunderbird crash if firefox is open (last Ubuntu updates) + USERS profile in network share Samba 4 → Thunderbird hang if firefox is open (last Ubuntu updates) + USERS profile in network share Samba 4

Updated

3 years ago
Component: Untriaged → Networking
Product: Thunderbird → MailNews Core
>Have to reboot the workstation to it starts working again
Restarting Firefox or Thunderbird them doesn't help ?
That sounds like something in the system is broken, probably the samba client.

I don't know how you mount the SMB directory but have you tried to remount them ?
(Reporter)

Comment 6

3 years ago
Hummm... 
Server Zentyal (Ubuntu base)

Workstations Ubuntu client 14.04 (update from 12.04)

mount from /etc/security/pam_mount.conf.xml (similar to this line)

# line 17: add the following in the volume definitions
<volume user="*" fstype="cifs" server="zentyal" path="%(DOMAIN_USER)" mountpoint="/h/%(DOMAIN_USER)" options="sec=ntlm,nodev,nosuid" />


The home from the user is not unmounted it can use all the rest, only thunderbird is unusable.

Like I saied Chrome + thunderbird no crashs.
(a) Thunderbird + Google Chrome => No problem, even when SAMBA share is used for Tb's profile directory.
(b) Thunderbird + Firefox               => Problem occurs.
(b) Thunderbird + Chrome + Firefox   => Problem occurs only on Thunderbird.
It may be problem like following.
(i) Firefox eats up memory, and Tb is swapped out.
(ii) Firefox interferes Tb.
Because Google Chrome is powerful memory eater than Firefox, I can't imagine (i).
   Google Chorome invokes one process per a Tab, but Firefox doesn't have such feature yet although requested.
(ii) can occur by;
   Use same directory as profile directory by Tb and Fx, then Fx wins.
   Tb's profile directory/system directory is placed under Fx's profile directory or Fx's system directory.
No such setup or similar setup?

When problem of (b) occurs, what hppens when Firefox is terminated? What happens if Firefix is restarted?
When problem of (b) occurs, what hppens when Thunderbird is terminated and restarted?

64bits Chrome? 32bits Chrome? 64bits Tb? 32bits Tb? 64bits Fx? 32bits Fx?
(Reporter)

Comment 8

3 years ago
(In reply to WADA from comment #7)
> (a) Thunderbird + Google Chrome => No problem, even when SAMBA share is used
> for Tb's profile directory.
> (b) Thunderbird + Firefox               => Problem occurs.
> (b) Thunderbird + Chrome + Firefox   => Problem occurs only on Thunderbird.
> It may be problem like following.
> (i) Firefox eats up memory, and Tb is swapped out.
> (ii) Firefox interferes Tb.
> Because Google Chrome is powerful memory eater than Firefox, I can't imagine
> (i).
>    Google Chorome invokes one process per a Tab, but Firefox doesn't have
> such feature yet although requested.
> (ii) can occur by;
>    Use same directory as profile directory by Tb and Fx, then Fx wins.

The profiles are in separated folders.


>    Tb's profile directory/system directory is placed under Fx's profile
> directory or Fx's system directory.
> No such setup or similar setup?
> 
I don't think this is what appends because is a standard Ubuntu instalation

> When problem of (b) occurs, what hppens when Firefox is terminated? What
> happens if Firefix is restarted?

Testing this right now

> When problem of (b) occurs, what hppens when Thunderbird is terminated and
> restarted?

The problem occurs again

> 
> 64bits Chrome? 32bits Chrome? 64bits Tb? 32bits Tb? 64bits Fx? 32bits Fx?

All 64 bits

Comment 9

2 years ago
Miguel, do you still see this with version 38 and 45?
Flags: needinfo?(xadrezmiguelpires)
(Reporter)

Comment 10

a year ago
Hi,
No I don't see this anymore
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Thanks. Assuming you didn't find this was caused by something other than Thunderbird, the bug status would be WORKSFORME
Flags: needinfo?(xadrezmiguelpires)
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.