Closed Bug 1129019 Opened 5 years ago Closed 2 years ago

test_IMAP_email_notification.py is failing intermittently, email notification is not received before timeout

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: viorela, Unassigned)

References

Details

Test test_IMAP_email_notification.py is failing on latest m-c: jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.smoke/330/HTML_Report/
The issue is reproducible locally, by running the automated test. Repro rate: 1/5.
I wasn't able to reproduce the failure manually.
The failure is caused by the fact that the notification is not received before timeout (30 + 60 sec)
This requires further investigation.

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette_test.py", line 283, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/email/test_IMAP_email_notification.py", line 50, in test_IMAP_email_notification
system.wait_for_notification_toaster_displayed(timeout=60)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/system/app.py", line 40, in wait_for_notification_toaster_displayed
self.wait_for_element_displayed(*self._notification_toaster_locator)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 50, in wait_for_element_displayed
lambda m: m.find_element(by, locator).is_displayed())
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.0 seconds

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	03 Feb 2015 06:16:28
Device firmware (incremental) 	eng.cltbld.20150203.091617
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	02 Feb 2015 11:50:21
Gaia revision 	ae5a1580da94
Gecko build 	20150203052826
Gecko revision 	b28f97ae095a
Gecko version 	38.0a1
Summary: test_IMAP_email_notification.py is failing intermittently, email notification is not received befor timeout → test_IMAP_email_notification.py is failing intermittently, email notification is not received before timeout
QA Whiteboard: [fxosqa-auto-backlog+]
There were some changes in bug 1132479 that might have fixed this.
Duplicate of this bug: 1181273
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.