Flame: while loading cnn webpage and scrolling at the same time, the browser dies

VERIFIED DUPLICATE of bug 1128042

Status

defect
VERIFIED DUPLICATE of bug 1128042
4 years ago
4 years ago

People

(Reporter: njpark, Assigned: cwiiis)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

Reporter

Description

4 years ago
Posted file cnn.log
STR:
Open Browser, go to a news site, (in my case, I went to: http://www.cnn.com/2015/02/02/entertainment/whitney-houston-daughter-hospitalized/index.html)
While loading, slowly scroll up / down 
Actual:
The browser exits unexpectedly
Expected:
The browser renders the webpage successfully.

Note:
My flame device is set to use 319MB of ram.

Version Info:
Gaia-Rev        ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ae5d04409cd9
Build-ID        20150203055658
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150203.093120
FW-Date         Tue Feb  3 09:31:32 EST 2015
Bootloader      L1TC000118D0
Reporter

Comment 1

4 years ago
Repro rate: 2 out of 5
Reporter

Comment 2

4 years ago
This also happens with 2.2 branch

Version info:
Gaia-Rev        cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
Build-ID        20150203002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150203.041704
FW-Date         Tue Feb  3 04:17:15 EST 2015
Bootloader      L1TC000118D0
Reporter

Comment 3

4 years ago
Browser can't seem to handle content heavy websites, especially if the site contains media clip
blocking-b2g: --- → 2.2?
Is this a regression, meaning it works on 2.1?
Keywords: qawanted
Reporter

Comment 5

4 years ago
So I tested it with 2.1 and 2.0.  In 2.1, the page loads, and the video starts playing automatically, but the browser OOMS after a minute or so.  Also it OOMs when there are rapid scrolling or orientation change, but it handles much better than 2.2 or master.

In 2.0, the video plays to the end, and scrolling/orientation changes does not cause any crashes.

IMO, there is a general memory footprint increase in 2.2 and onwards.  In the bug 1133144, camera oom issue was raised, but it seems that other issues might contribute to it as well.

Version Used:
2.1
Gaia-Rev        a43e3cdf8783e9d87156d47b8bfff0f5f44f9e2e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/5653f229724f
Build-ID        20150219001626
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150219.034905
FW-Date         Thu Feb 19 03:49:15 EST 2015
Bootloader      L1TC000118D0

2.0
Gaia-Rev        ecb1bbc3b9c00f82df172427f65d6f67e34ed533
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c76040f40105
Build-ID        20150219000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150219.032904
FW-Date         Thu Feb 19 03:29:14 EST 2015
Bootloader      L1TC000118D0
I was attempting to reproduce this issue but had no luck on central (latest and a build around the time of the one in comment 0) or on 2.1 but No-Jun has completed the request now so removing the tag.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150219061637
Gaia: 373df4bec2c20228f45be0b24111252171f925e9
Gecko: 135202bfc102
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 3.0
BuildID: 20150219070727
Gaia: f88d304eee04c6e515c942b19464388e6488edec
Gecko: 986e840a2979
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 3.0
BuildID: 20150203060340
Gaia: 321c69857c36889ad0f8f53d772dc72bc2cd0951
Gecko: 58e4264903ba
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
I think there have been several websites that have been reported to OOM.

Here is one example. The Tumblr website also encounters an OOM when scrolling. Please see bug 1063854
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 8

4 years ago
Triage is blocking because this reads like a performance regression.
blocking-b2g: 2.2? → 2.2+
Keywords: regression

Comment 9

4 years ago
Hi Candice, need your help to follow up on this, thank you.
Flags: needinfo?(cserran)
Flags: needinfo?(cserran)
Whiteboard: [systemsfe]
Can we test again? We fixed some gfx issues.
Keywords: qawanted
(In reply to Gregor Wagner [:gwagner] from comment #10)
> Can we test again? We fixed some gfx issues.

This issue is still occurring on today's Flame 3.0. The issue seems have a higher repro rate for Wifi connections - higher chance to LMK if contents load in faster, it seems.

I reproduced the issue 1 out of 3 on a 2/3 build, and 1 out of 1 on today's build.

Device: Flame 3.0 Master (full flash, 319MB mem)
BuildID: 20150305010212
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 56492f7244a9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee

Comment 12

4 years ago
Taking to investigate the cause.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Reporter

Updated

4 years ago
See Also: → 1128042
Assignee

Comment 13

4 years ago
Can't reproduce this on master with the steps from comment #0, will flash to 2.2 and try there.
Assignee

Comment 14

4 years ago
Can't reproduce this on 2.2 either... Reporter, can you still reproduce this? Perhaps it was fixed by recent gfx uplifts?

I'm trying this on a 319mb flame-kk.

It might be that I get a different CNN being in the UK, the video doesn't auto-play for me certainly.
Flags: needinfo?(npark)
Reporter

Comment 15

4 years ago
I just checked it again on the latest master branch, and I do see the performance improvement compared to the build that I found it in. Now it OOMs only when I also perform pinch actions and screen rotation - simple scrolling will not OOM.  I think the core issue is still there, but it is actually now being tracked by bug 1128042.

So I think we should close this bug and point to the one that's currently being worked on, because the bug does not occur when strictly following the STR.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(npark)
Resolution: --- → DUPLICATE
Duplicate of bug: 1128042
I cannot reproduce this on 2.2 branch either.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.