[RTL][Email] "Sent Using Firefox OS" is left-aligned.

RESOLVED WORKSFORME

Status

defect
P2
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ychung, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
Description:
. 
   
Repro Steps:
1) Update a Flame device to BuildID: 20150203055641.
2) Set the device language in Arabic under Settings > Language.
3) Open Email app, and set up an account.
4) After logging in, observe the string "Sent Using Firefox OS" under "Signature" on the "New Account" screen.

Actual:
The string "Sent Using Firefox OS" is left-aligned.
  
Expected: 
The string "Sent Using Firefox OS" is right-aligned.

* This issue reproduces on both Flame 2.2 and Master:
  
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150203002504
Gaia: cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko: 11d93135c678
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame Master (319mb, full flash)
Build ID: 20150203055641
Gaia: ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko: ae5d04409cd9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
  
Repro frequency: 100%
See attached: screenshot
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Reporter

Comment 1

4 years ago
Here's the description:

When setting up an email account, the string "Sent Using Firefox OS" under "Signature" on the "New Account" screen is left-aligned.
Test case has been added in moztrap:https://moztrap.mozilla.org/manage/case/15285/
Flags: in-moztrap+
feature-b2g: --- → 2.2+
I just flashed latest Gaia/Gecko master, and do not see this, the text is left aligned, see screenshot. This is also how it shows up if the text is in English, but shown in Arabic UI.

So going to close as a worksforme, probably fixed by an intermediate change. I have not checked the 2.2 branch, but I do not know of any email changes that would be on master but not on 2.2 that would affect this.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.