Closed Bug 1129238 Opened 5 years ago Closed 5 years ago

[Settings][Call Barring] "International except Home Country" is truncated in English

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: tchevalier, Assigned: fcampo)

References

Details

(Keywords: l12y)

Attachments

(5 files)

Attached image Issue, Flame 3.0
Go to Settings, Call settings > Call barring:

There's an issue with International roaming label: it's truncated even in English and the main info is not displayed to the user. The user can't understand anything about this option.

The full string that has landed is "International except Home Country" and is truncated as "International except …". Initially it was "International roaming" in the specs attached to bug 910552.

And even "International roaming" is probably still too long for some locales.
I'd say we need way shorter string here, or a different UI (multi-lines switch element, etc.), or both.

FWIW, we had a similar issue (too long label associated to a switch) this week in bug 1114453.

Flagging UX to see what we can do here
Flags: needinfo?(firefoxos-ux-bugzilla)
Setting also ni to Pau and Jenny as they did an reviewed the Call Barring spec
Flags: needinfo?(jelee)
Flags: needinfo?(b.pmm)
Hi all,

I think the string is fine, and we have a two-line-title layout for toggle to apply. so if Pau doesn't see the need to make change to the string, we can change the layout. Thanks!
Flags: needinfo?(jelee)
Hi,

I think that if the system provides a way to display a two-line-title layout we can apply it.
But I would like to see how it is displayed once it is implemented to be sure the layout fits well with the rest of elements of the screen.

Thanks :)
Flags: needinfo?(b.pmm)
Attached image two lines text
this is how it looks on the flame
Attachment #8559065 - Flags: review?(b.pmm)
Comment on attachment 8559065 [details]
two lines text

Looks ok to me. Thanks Fernando!
Attachment #8559065 - Flags: review?(b.pmm) → review+
simple CSS tweak for not wrapping the text on spans
Attachment #8559087 - Flags: review?(arthur.chen)
Thanks for the quick fix guys, looks definitely better :)
Clearing UX NI.
Flags: needinfo?(firefoxos-ux-bugzilla)
Comment on attachment 8559087 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/27911

Looks good. r=me.
Attachment #8559087 - Flags: review?(arthur.chen) → review+
Triage: blocking, truncation lets user can't understand the meaning correctly
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → fernando.campo
Status: NEW → ASSIGNED
Attached file Approval 2.2
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 910552
[User impact] if declined: user won't be able to read the option
[Testing completed]: manual testing with UX approval
[Risk to taking this patch] (and alternatives if risky): very low risk, small visual change
[String changes made]: -
Attachment #8560362 - Flags: approval-gaia-v2.2?
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27911

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified fixed with current master build on Flame.
I am sorry to have seen this late. It would really be nice if we could use a better label here later on; I have no idea what this means, in English. :)
Comment on attachment 8560362 [details]
Approval 2.2

Please file a follow-up if needed to address Stephany's concern.
Attachment #8560362 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The string "International except Home Country" appears in two lines without any truncation in English.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150319010201
Gaia: c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko: cf1060d8ce9f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150319002500
Gaia: 9043c11f699c15bb6072422d1dad6518d1b5ddda
Gecko: c0442d170bec
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.