SystemMessageInternal 1423035594631 : Unknown pendingPromise messageID. This seems a bug!!

RESOLVED FIXED in Firefox 38

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kanru, Assigned: baku)

Tracking

unspecified
mozilla38
Points:
---

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
While debugging bug 1126119 I found these error messages

I/Gecko   ( 3083): -- SystemMessageInternal 1423035594464 : received SystemMessageManager:GetPendingMessages activity for app://gallery.gaiamobile.org/index.html#pick @ app://gallery.gaiamobile.org/manifest.webapp
I/Gecko   ( 3083): -- SystemMessageInternal 1423035594631 : received SystemMessageManager:HandleMessageDone activity with msgID undefined for app://gallery.gaiamobile.org/index.html#pick @ app://gallery.gaiamobile.org/manifest.webapp - promise rejected: false
I/Gecko   ( 3083): -- SystemMessageInternal 1423035594631 : Unknown pendingPromise messageID. This seems a bug!!

Which seems caused by http://mxr.mozilla.org/mozilla-central/source/dom/messages/SystemMessageInternal.js?rev=f15ef701bdf2#500

I'm not sure if this is real issue. fabrice?
(Reporter)

Updated

4 years ago
Flags: needinfo?(fabrice)
That's from baku's latest changes (see http://mxr.mozilla.org/mozilla-central/source/dom/messages/SystemMessageInternal.js?rev=f15ef701bdf2#785)

Andrea? "This seems a bug!!"
Flags: needinfo?(fabrice) → needinfo?(amarchesini)
(Assignee)

Comment 2

4 years ago
kanru, can you reproduce this issue 100% of the times?
Do you have a small test I can use it?
Flags: needinfo?(amarchesini) → needinfo?(kchen)
(Reporter)

Comment 3

4 years ago
I could reproduce it 100% of the times. Just uncomment the debug function in SystemMessageInternal.js and launch any app with activity. For example, I long tap the homescreen background and choose the Gallery app to choose background.
Flags: needinfo?(kchen)
(Assignee)

Updated

4 years ago
Assignee: nobody → amarchesini
(Assignee)

Comment 4

4 years ago
Created attachment 8560425 [details] [diff] [review]
id.patch

We need the msgID also when the GetPendingMessages is called.
It doesn't seem that the messageID is used anywhere else, so it should not be a problem to keep it and send it to the child.
Attachment #8560425 - Flags: review?(fabrice)
Attachment #8560425 - Flags: review?(fabrice) → review+
(Assignee)

Comment 5

4 years ago
Created attachment 8560842 [details] [diff] [review]
id.patch

https://treeherder.mozilla.org/#/jobs?repo=try&revision=11d06a2a6747

If green, checkin-needed.
Attachment #8560425 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Reporter)

Comment 6

4 years ago
Andrea, the latest patch seems to contain unintended modifications to Blob.cpp
Flags: needinfo?(amarchesini)
(Reporter)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 7

4 years ago
Yeah... I did mix 2 patches in one. Here the new try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9e5531980e4d
I'll mark this bug checkin-needed if this is fully green.
Flags: needinfo?(amarchesini)
https://hg.mozilla.org/mozilla-central/rev/7accb67a2e6f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.