Firefox 35.0 does not use Proxy settings with flash

VERIFIED WORKSFORME

Status

()

Firefox
Untriaged
VERIFIED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Markus Kopp, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

Since Firefox 35.0 the proxy settings of Firefox are not used by the flash Plugin.
To reproduce: Use a Proxy, do not allow direct Connections to Internet, try to view a Web Video, for example on http://www.handelsblatt.com/video/
Operating System is Windows 7.


Actual results:

The Flash player can not connect to the Internet. You see the Message VE_FMS_CONNECT_FAILED in Flash player. I can see how the flash process tries to connect without using the proxy.
When setting dom.ipc.plugins.flash.disable-protected-mode to true the proxy settings are used in Flash. With this setting proxy Authentication fails very often and proxy Password has to be entered several times when setting the preference.
I have seen this on several maschines and different Websites since Firefox 35.0.


Expected results:

Playing the Video.
(Reporter)

Comment 1

4 years ago
Problem is solved in Firefox 35.0.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
Tried this again and the Error ist not resolved in 35.0.1. Ist there anything i can do, for example tracing?
(Reporter)

Comment 3

3 years ago
If i look at the running Processes the plugin container ist running all the time. The Flash player plugin also. The first video is displayed (Commercial). The second video is not loaded (FME Connect Failed).
You need to log in before you can comment on or make changes to this bug.