Select a list and the Edit menu either displays Delete Card or Delete Address Book

VERIFIED FIXED in mozilla1.2alpha

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Ninoschka Baca, Assigned: standard8)

Tracking

Trunk
mozilla1.2alpha
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nab-mlist)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Trunk build 2001-11-30-03: WinMe

Overview: When a mail list is selected then the Edit menu either shows a Delete
Card or Delete Address Book menu item. It should state Delete List.

Steps to reproduce:
1. Select a list in the results pane (or the directory pane)
2. Select the Edit menu

Actual Results:
- If the list selected is in the results pane then it dispalys Edit|Delete Card
- If the list selected is in the directory pane then it displays Edit|Address Book

Expected Results:
Anytime a list is selected, either from the results pane or directory pane, then
the Edit menu should display a Delete List menu item.

Updated

17 years ago
Status: NEW → ASSIGNED
Summary: Select a list and the Edit menu either displays Delete Card or Delete Address Book → Select a list and the Edit menu either displays Delete Card or Delete Address Book
Target Milestone: --- → mozilla1.2
(Reporter)

Updated

17 years ago
Whiteboard: nab-mlist

Updated

16 years ago
Blocks: 136757
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
Product: Browser → Seamonkey
(Assignee)

Comment 2

14 years ago
I have a fix for this bug - therefore taking and cc'ing Seth, I'm also seeing it
on Linux (build id below) so setting OS to all.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041129
Assignee: sspitzer → mark
OS: Windows ME → All
(Assignee)

Comment 3

14 years ago
Created attachment 167347 [details] [diff] [review]
Patch to dynamically update the delete item menu.

This patch dynamically updates the delete item menu correctly according to the
currently selected item(s).

There is also a modification to ensure that the menu is updated as soon as the
selection on the results pane is changed (this didn't work before - you had to
focus on another window and then go back to it for the menu item to change).
(Assignee)

Updated

14 years ago
Attachment #167347 - Flags: review?(neil.parkwaycc.co.uk)

Comment 4

14 years ago
Comment on attachment 167347 [details] [diff] [review]
Patch to dynamically update the delete item menu.

>-        // fix me, don't update on isCommandEnabled
Ideally this should still be fixed, so don't delete the comment...

>   isCommandEnabled: function(command)
>   {
>+    var selectedDir = GetSelectedDirectory();
This is a bad place to put this, because this function gets called a fair
amount; perhaps you could inline the call in the cmd_delete case?
(Assignee)

Updated

14 years ago
Attachment #167347 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 5

14 years ago
Created attachment 167452 [details] [diff] [review]
Patch v2

Revised, don't delete comment and reworked the moving of GetSelectedDirectory.
Attachment #167347 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #167452 - Flags: review?(neil.parkwaycc.co.uk)

Comment 6

14 years ago
Comment on attachment 167452 [details] [diff] [review]
Patch v2

Right, this way should work too (I only tested attachment 167347 [details] [diff] [review]).
Attachment #167452 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

14 years ago
Attachment #167452 - Flags: superreview?(bienvenu)

Comment 7

14 years ago
Comment on attachment 167452 [details] [diff] [review]
Patch v2

+	   if (GetDirectoryFromURI(selectedDir).isMailList)
+	     goSetMenuValue(command, "valueList");
+	   else
+	     goSetMenuValue(command, "valueAddressBook");

can be

goSetMenuValue(command, GetDirectoryFromURI(selectedDir).isMailList ?
"valueList" : "valueAddressBook"; 

sr=bienvenu with that nit.
Attachment #167452 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 8

14 years ago
Created attachment 167563 [details] [diff] [review]
Patch for checkin

Adding patch for checkin incorporating fix for bienview's comment.
(Assignee)

Comment 9

14 years ago
Patch checked in to trunk, marking as fixed.

2004-12-01 14:25	timeless%mozdev.org 	mozilla/ mailnews/ addrbook/ resources/
content/ addressbook.xul 	1.171 	4/1
2004-12-01 14:25	timeless%mozdev.org 	mozilla/ mailnews/ addrbook/ resources/
content/ abResultsPaneOverlay.xul 	1.18 	1/1 
2004-12-01 14:25	timeless%mozdev.org 	mozilla/ mailnews/ addrbook/ resources/
content/ abCommon.js 	1.99 	21/6 
2004-12-01 14:25	timeless%mozdev.org 	mozilla/ mailnews/ addrbook/ resources/
locale/ en-US/ abMainWindow.dtd 	1.55 	3/0 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Verified FIXED using build 2005-07-10-05 on SeaMonkey trunk, Windows XP: it
correctly states "Delete List".
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Blocks: 440513
You need to log in before you can comment on or make changes to this bug.