[RTL][Notification Tray] Opening Usage via Tray will open Whitescreen App, can close via Tray; locking in whitescreen will pitfall phone

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: etienne)

Tracking

unspecified
2.2 S7 (6mar)
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(4 attachments)

Reporter

Description

4 years ago
Description:
In an RTL language, the user may reach a pitfall state via navigation of the Notification Tray. Accessing usage via the tray will load up a whitescreen app that, if killed via Task Manager, cannot be navigated away via 'Home' button. Using the notification tray, the user may recover from this app. However if the user were to lock their phone within that app, they will become blocked, as the user may not access the tray from lockscreen, nor seemingly unlock the phone.


Repro Steps:
1) Update a Flame to 20150204010225
2) Open the 'Settings' app.
3) Locate 'Languages'.
4) Change to a RTL language (documented in Arabic.)
5) Slide down Notification Tray from top of screen.
6) Tap SIM Widget near bottom to open usage.
7) Observe whitescreen.
8) Kill app via task manager.
9) Lock phone.

Actual:
7) Spawns whitescreen app, confusing to the user.
9) User reaches pitfall, must pull battery to recover.

Expected:
SIM Widget spawns Usage app without whitescreen.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150204010225
Gaia: dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko: 0c2f7434c325
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

--------------------------------------------------
Issue REPROES to an extent on flame 2.2 devices:
Results:
7) Spawns whitescreen app, confusing to the user.
- Can recover via homescreen, or killing the app (step 8).
9) User reaches pitfall, must pull battery to recover.
- This also occurs if locking when the whitescreen app is open.

BuildID: 20150204002509
Gaia: a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gecko: 8669c26fd4a5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
video- http://youtu.be/oRdhaqompvU
logcat
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][rtl-impact]
Nominating to block based upon pitfall scenario.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
blocking-b2g: 2.2? → 2.2+
triage: P1 to fix the launching of Usage app. 

I do see the white screen when entering Usage from the notification tray, but it returns normally to homescreen if I press home key or kill the Usage app. Also, if I press Home key to return to homescreen and then pull down notification try again, I can succeed when opening the Usage app from there on the second try.
Priority: -- → P1
feature-b2g: --- → 2.2+

Updated

4 years ago
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing] [systemsfe]
Dear Candice,
Could you help to find someone help for this bug? Thanks!
Flags: needinfo?(cserran)
Component: Gaia::System::Window Mgmt → Gaia::Cost Control
Assignee: nobody → nefzaoui
Flags: needinfo?(cserran)
Francisco, is your team tracking this?
Flags: needinfo?(francisco)
Whiteboard: [3.0-Daily-Testing] [systemsfe] → [3.0-Daily-Testing]
Not yet, let's ask Salva if he is aware of this.

Salva is this familiar to you?
Flags: needinfo?(francisco) → needinfo?(salva)
Can we try this again? I'm not reproducing the bug. What's happening to me with today's build (master Gaia) is:

  1. The new SIM message is appearing with proper RTL alignment (which is not seen in the attached video).
  2. When tapping on it, another application distinct than Cost Control is open but the Cost Control is still there, only not shown and accessible via task switcher.
  3. Once you access the Cost Control app, it is working well.

Can we test the STR again, please?
Flags: needinfo?(salva)
Keywords: qawanted
Issue DOES occur on latest Flame 3.0 Master

Following STR in comment 0 this issue reproduces. When opening Cost Control from utility tray a grey screen appears (status bar is still visible.) Long pressing home button reveals that the current app is cost control. Sliding up to kill cost control and then, without exiting task manager, locking screen by short pressing power button results in user being presented with inescapable white screen when user turns screen on again. User must pull battery to exit this screen.

Device: Flame 3.0 Master
BuildID: 20150213010213
Gaia: 2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko: 2f5c5ec1a24b
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)

Updated

4 years ago
Status: NEW → ASSIGNED
Could we have an update on this please ?
Flags: needinfo?(jocheng)
(In reply to David Scravaglieri [:scravag] from comment #8)
> Could we have an update on this please ?

Unfortunately I'm not gonna be able to continue working on this.
Assignee: nefzaoui → nobody

Comment 10

4 years ago
The day of Feature Landing is not the day that it's acceptable to say we're no longer working on a P1 for 2.2 that is blocking the release and try to have it reassigned. Flagging Loic on this one. 

Flagging Gregor to see if we have anyone who can take this.
Flags: needinfo?(loic)
Flags: needinfo?(anygregor)
(In reply to Stephany Wilkes from comment #10)
> The day of Feature Landing is not the day that it's acceptable to say we're
> no longer working on a P1 for 2.2 that is blocking the release and try to
> have it reassigned. Flagging Loic on this one. 
> 
> Flagging Gregor to see if we have anyone who can take this.

Cost control is not part of systems-fe. back to comment 4.
Flags: needinfo?(anygregor)

Comment 12

4 years ago
I'll talk to Candice. This is more about notification tray than Cost Control, and I know of no one not in Taipei and on CNY who can take this.

Comment 13

4 years ago
Francisco, Candice pointed me to you: is there anyone you can think of who may be able to help during Chinese New Year? Thanks!
Flags: needinfo?(francisco)
Hi,

I've been talking with Marina, part of the Telefonica team that implemented Cost Control.

She has been taking a look to the issue and says that it's a window management problem, cc is not even launched.

ni her to give more information about it.
Flags: needinfo?(francisco) → needinfo?(marina.rodrigueziglesias)
Hi, 
I was testing this bug, IMHO it's a window management problem because:
  * If I don't kill the App when the white screen appears, and I only minimize it, I can see on the left side of the homescreen a vertical layer (screenshot is attached). This layer is hidden or showed depending on the language. (It's visible on RTL languages and hidden on other languages like English).
  * If I go to the settings, sliding down the utility tray, and pressing the settings button, when the White screen is showed, it desappears and all is correctly shown.

I hope this can be useful, for all this, I've changed the component to Windows management.

Best regards, 
Marina
Component: Gaia::Cost Control → Gaia::System::Window Mgmt
Flags: needinfo?(marina.rodrigueziglesias)
Etienne, Alive, Mike, could you please comment on Marina ?
Thanks.
Flags: needinfo?(mhenretty)
Flags: needinfo?(loic)
Flags: needinfo?(jocheng)
Flags: needinfo?(etienne)
Flags: needinfo?(alive)
Assignee

Comment 18

4 years ago
Reproducing the issue here and seeing system app errors in logcat... will have a look today!
Assignee: nobody → etienne
Flags: needinfo?(etienne)
(In reply to Etienne Segonzac (:etienne) from comment #18)
> Reproducing the issue here and seeing system app errors in logcat... will
> have a look today!

This is in good hands.
Flags: needinfo?(mhenretty)
Assignee

Comment 21

4 years ago
Comment on attachment 8570734 [details] [review]
[gaia] etiennesegonzac:bug-1129598 > mozilla-b2g:master

Everything is bad and we should feel bad ;)

* because of a double click handler the cost control widget sends 2 MozActivity requests at the same time to open its own app
* the window manager then errors because it's not hardened against this edge case
* the costcontrol app finally opens and reflows constantly ~60 time per second because of a building block animation on <progress> (I bisected, it has been like that for almost a year! (bug 997084))
* and an rtl-only gfx glitch causes the findmyphone app (completely white) to display on top of everything else

This fixes it.
Attachment #8570734 - Flags: review?(kgrandon)
Comment on attachment 8570734 [details] [review]
[gaia] etiennesegonzac:bug-1129598 > mozilla-b2g:master

I unfortunately won't be able to manually test this soon as I forgot my sim card at home, but this looks simple enough that I feel fine adding an R+ here. Looks like a pain to track this stuff down, nice job.
Attachment #8570734 - Flags: review?(kgrandon) → review+
Assignee

Updated

4 years ago
Flags: needinfo?(alive)
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This issue is verified fixed on Flame Master.

Result: Usage app appears properly when opened via notification tray.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

==================================
Leaving verifyme for 2.2 uplift/verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(etienne)
Target Milestone: --- → 2.2 S7 (6mar)
Assignee

Comment 26

4 years ago
Comment on attachment 8570734 [details] [review]
[gaia] etiennesegonzac:bug-1129598 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): probably a gfx rtl bug
[User impact] if declined: a completely white window can get stuck on top of everything else on screen
[Testing completed]: the STR from the bug + the patch has been on master for while without any issue
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Flags: needinfo?(etienne)
Attachment #8570734 - Flags: approval-gaia-v2.2?
Attachment #8570734 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 28

4 years ago
Posted video verify_pass.3gp
This issue has been verified as "Pass" on latest build of Flame 2.2 by STR in comment 0.
Result: Usage app appears properly when opened via notification tray.
See attachment: verify_pass.3gp
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150617002504
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150617.040422
Firmware Date          Wed Jun 17 04:04:34 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.