[Contacts] - The font on the contact information page listing the Birthday and Anniversary is way too small.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: hola)

Tracking

({regression})

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
In the contact app when creating or editing a contact there is an option to add a contact's birthday or anniversary. If you do so, this info will show up in the contact's details page but the date for either listing is way too small compared to the rest of the font sizes.

Repro Steps:
1) Update a Flame to 20150204010225
2) Launch Contact App
3) Create a contact with a birthday and anniversary date info
4) View that contact's details page

Actual:
Font for Birthday and anniversary is way too tiny

Expected:
Normal sized font

Environmental Variables:
Device: Flame 3.0
Build ID: 20150204010225
Gaia: dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko: 0c2f7434c325
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 5/5
See attached: screenshot
--------------------------------------------------------------------------------------------------------
This issue does NOT reproduce in 2.2 

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Visual regression of a core feature, poor UX.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
A regression window might not be necessary here. What do you think, Francisco?
Flags: needinfo?(francisco)
QA Whiteboard: [QAnalyst-Triage+]
Agree don't think we need the regression window.

Johan, do you think is bad enough for being a blocker?
Flags: needinfo?(francisco) → needinfo?(jlorenzo)
To me, it would be a blocker.

Triage: Nice to have, not bad enough to hold the current 3.0 release.
Blocks: 1096825
blocking-b2g: 3.0? → -
Flags: needinfo?(jlorenzo)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> To me, it would be a blocker.

it's an ugly regression, let's try to fix it and ask for approval to 2.2 branch.

Adrian, can you have a look at it, please? Thanks a lot!
Flags: needinfo?(hola)
(Assignee)

Comment 6

4 years ago
Regression due to css change in bug 1058790. This is a RTL issue so let's ask Francisco how we should handle this field and add this bug to the RTL meta bug. In the worst case, we can just add a css rule to fix this case.
Blocks: contacts-rtl
Flags: needinfo?(hola) → needinfo?(francisco)
blocking-b2g: - → 2.2+
Looks like https://bugzilla.mozilla.org/show_bug.cgi?id=1058790 was uplifted, so it may happen in 2.2 as well, hence changing the status.
Priority: -- → P2
Confirmed on 2.2. The issue appears on:
Build ID               20150216162504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d823f7be4c
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.201649
Firmware Date          Mon Feb 16 20:17:00 EST 2015
Bootloader             L1TC000118D0
Hi Adrian, as this has been uplift to 2.2, can you provide a patch for solving both situations?
Flags: needinfo?(francisco) → needinfo?(hola)
(Assignee)

Comment 10

4 years ago
Ok, I'm taking it!
Assignee: nobody → hola
Flags: needinfo?(hola)
(Assignee)

Comment 12

4 years ago
Comment on attachment 8566557 [details] [review]
[gaia] ADLR-es:rtl-css-fix > mozilla-b2g:master

Really minimal CSS fix.
Attachment #8566557 - Flags: review?(jmcf)
This is not an RTL specific bug, it's happening for LTR too and it's been already triaged.

Fix seems really simple, so we will ask for approval 2.2
No longer blocks: contacts-rtl
Comment on attachment 8566557 [details] [review]
[gaia] ADLR-es:rtl-css-fix > mozilla-b2g:master

thanks Adrian
Attachment #8566557 - Flags: review?(jmcf) → review+

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Comment 16

4 years ago
Comment on attachment 8566557 [details] [review]
[gaia] ADLR-es:rtl-css-fix > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1058790
[User impact] if declined: The dates in the contact detail view will be rendered too small.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Very low, just a small CSS fix to re-enable some CSS rules.
[String changes made]: None
Attachment #8566557 - Flags: approval-gaia-v2.2?
Attachment #8566557 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The Birthday and Anniversary appear in a normal size font.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150319010201
Gaia: c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko: cf1060d8ce9f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150319002500
Gaia: 9043c11f699c15bb6072422d1dad6518d1b5ddda
Gecko: c0442d170bec
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.