Closed Bug 1129720 Opened 5 years ago Closed 5 years ago

[EME] IPDL errors when using MSE decoder-per-segment

Categories

(Core :: Audio/Video, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1130932

People

(Reporter: cpearce, Assigned: eflores)

References

(Blocks 1 open bug)

Details

If you set media.mediasource.decoder-per-segment=true, MSE will instantiate a new decoder for every append made to a source buffer. This simulates a lot of little seeks.

If we load http://people.mozilla.org/~cpearce/mse-clearkey/ with that pref set, on tab close we see lots of IPDL errors:

[7616] WARNING: Trying to use a dead GMP decrypter!: file c:\Users\cpearce\src\mozilla\purple\dom\media\gmp\GMPDecryptorParent.cpp, line 273
IPDL protocol error: Handler for KeyStatusChanged returned error code

###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x520014,name=PGMPDecryptor::Msg_KeyStatusChanged) Processing error: message was deserialized, but the handler returned false (indicating failure)

We should figure out what these errors are, and fix them.
Fallout from the ClearKey refactor/WMF changes, I'm fairly sure. Not fatal, afaict.
Assignee: nobody → edwin
Status: NEW → ASSIGNED
It looks like the symptom described in bug 1130932.
Depends on: 1130932
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1130932
Mass update firefox-status to track EME uplift.
No longer blocks: 1032660
You need to log in before you can comment on or make changes to this bug.