[B2G][Browser][Video Streaming] Streaming of video content on youtube breaks approximately 10 minutes in[B2G].

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: pbylenga, Assigned: sotaro)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
Streaming a video longer than 10 minutes, the video content will break (corrupted, usually turns black), audio continues however.  Pausing resuming does not recover.  Logcat has the following error in it:

02-04 14:39:14.366 W/SoftAAC2( 8469): AAC decoder returned error 16386, substituting silence
02-04 14:39:14.366 W/SoftAAC2( 8469): AAC decoder returned error 16388, substituting silence
02-04 14:39:14.366 W/SoftAAC2( 8469): AAC decoder returned error 16391, substituting silence

Repro Steps:
1) Update a Flame to 20150204010225
2) With Data/Wifi Launch Browser
3) Navigate to Youtube.com and play a video longer than 10 minutes


Actual:
Around 10 minute mark video stream breaks


Expected:
video stream is preserved till end


Environmental Variables:
Device: Flame 3.0
Build ID: 20150204010225
Gaia: dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko: 0c2f7434c325
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: (5/5, 100%)
See attached: logcat
(Reporter)

Comment 1

4 years ago
qawanted for branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
(Reporter)

Updated

4 years ago
Summary: [Browser][Video Streaming] Streaming of video content on youtube breaks approximately 10 minutes in. → [B2G][Browser][Video Streaming] Streaming of video content on youtube breaks approximately 10 minutes in[B2G].
(Reporter)

Updated

4 years ago
Whiteboard: [3.0-Daily-Testing]
A few more settings/variables I tried when reproducing the bug (I have not tried without those so I don't know if they play a factor):
- Video was streamed using cellular data connection
- Screen timeout was set to Never in Settings > Display
- Youtube video was viewed in portrait mode, non-full screen, non HD
- Phone was plugged in during streaming
- When playing the video, tapped at least once on video to bring up the controls, and utility tray was pulled down at least once

This issue reproduces on Flame 2.2. Video becomes corrupt after 9 minutes into the video. Repro rate: 1/1.

Device: Flame 2.2 (shallow flash, 319MB mem)
BuildID: 20150204130631
Gaia: c2047a46e29696238e9b4c9caaba47736421449a
Gecko: adfba0a07e9b
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

---------

This issue does NOT reproduce on Flame 2.1. Video does not become corrupt and I was able to successfully stream a 23-minute video. Repro rate: 0/1.

Device: Flame 2.1 (shallow flash, 319MB mem)
BuildID: 20150203181022
Gaia: 17bf14f12e43043654498330d610d469b8b55e64
Gecko: bdebcc47ec7a
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Assignee)

Updated

4 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Updated

4 years ago
Assignee: nobody → ychung
Assignee: ychung → nobody
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: ychung → jmercado
QA Contact: jmercado → ychung
Initial Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141106040623
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 41adad987d82
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141106045123
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 0c66a9fd9085
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 0c66a9fd9085

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 41adad987d82

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=41adad987d82&tochange=0c66a9fd9085

-------------------------------------
I will keep working on for the Mozilla-inbound regression window.

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 4

4 years ago
I take this bug.
Assignee: nobody → sotaro.ikeda.g
Mozilla-inbound Regression Window

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141105161150
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 9fa06a2e1a98
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141105163110
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: f1ec1b1b0048
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: f1ec1b1b0048

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 9fa06a2e1a98

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9fa06a2e1a98&tochange=f1ec1b1b0048

possibly caused by bug 1085186
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Robert, can you take a look at this please? Looks like the work done on bug 1085186 might have caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(roc)
(Reporter)

Comment 7

4 years ago
NI also on reviewer of the patch to take a look.
Flags: needinfo?(cpearce)
Flags: needinfo?(cpearce)
(Assignee)

Comment 8

4 years ago
I tried to reproduce the problem several times. But still failed to reproduce it :-(
(Assignee)

Comment 9

4 years ago
I still could not reproduce the problem. But I seems to face a different problem. If I did a lot of seeking during long(more than 1 hour) youtube video playback, video playback became not progress.
(Assignee)

Comment 10

4 years ago
(In reply to Peter Bylenga [:PBylenga] from comment #0)
> Created attachment 8559515 [details]
> streaming_youtube_content_log.txt
> 
> Description:
> Streaming a video longer than 10 minutes, the video content will break
> (corrupted, usually turns black), audio continues however.  Pausing resuming
> does not recover.  Logcat has the following error in it:
> 
> 02-04 14:39:14.366 W/SoftAAC2( 8469): AAC decoder returned error 16386,
> substituting silence
> 02-04 14:39:14.366 W/SoftAAC2( 8469): AAC decoder returned error 16388,
> substituting silence
> 02-04 14:39:14.366 W/SoftAAC2( 8469): AAC decoder returned error 16391,
> substituting silence
> 
> Repro Steps:
> 1) Update a Flame to 20150204010225
> 2) With Data/Wifi Launch Browser
> 3) Navigate to Youtube.com and play a video longer than 10 minutes
> 
> 
> Actual:
> Around 10 minute mark video stream breaks

Peter, can you explain how the video playback is broken. Is it clear from UI?
Flags: needinfo?(pbylenga)
(Reporter)

Comment 11

4 years ago
Typically there's some checkerboarding anomalies and then the video portion is black/blank. Audio persists though.
Flags: needinfo?(pbylenga)
(Assignee)

Comment 12

4 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #9)
> I still could not reproduce the problem. But I seems to face a different
> problem. If I did a lot of seeking during long(more than 1 hour) youtube
> video playback, video playback became not progress.

This was my misunderstanding. Just by play button twice, the video was started to playback.
(Assignee)

Comment 13

4 years ago
(In reply to Peter Bylenga [:PBylenga] from comment #11)
> Typically there's some checkerboarding anomalies and then the video portion
> is black/blank. Audio persists though.

Thanks.
Hi, Sotaro, there is no update for almost a month. Can you share with us the latest update? 
Thank you.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 15

4 years ago
(In reply to Kevin Hu [:khu] from comment #14)
> Hi, Sotaro, there is no update for almost a month. Can you share with us the
> latest update? 
> Thank you.

Sorry, I failed to reproduce the problem.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 16

4 years ago
njpark, can you reproduce the bug?
Flags: needinfo?(npark)
hmm, on today's master build, I tried two videos with one on fullscreen mode and the other on the regular mode, but they both passed the 10 min mark and plays fine.

Gaia-Rev        9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Build-ID        20150323010204
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150323.043448
FW-Date         Mon Mar 23 04:34:57 EDT 2015
Bootloader      L1TC000118D0

Peter, could you recheck whether this is still happening on your side?
Flags: needinfo?(npark) → needinfo?(pbylenga)
(Reporter)

Comment 18

4 years ago
I tried 4 times couldn't reproduce.  Adding qawanted to check before we close this as a WFM.
Flags: needinfo?(pbylenga)
Keywords: qawanted
(Reporter)

Comment 19

4 years ago
Actually we should also have qawanted check 2.2 since we're blocking there, may need a reverse regression window to find out what fixed us for Master and see if we can get an uplift.
QA Contact: ktucker
I watched 5 videos that were over 10 minutes each on Flame 3.0 and Flame 2.2

All videos played as expected without issue.

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150324010202
Gaia: efebbafd12fc42ddcd378948b683a51106517660
Gecko: 840cfd5bc971
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150324002504
Gaia: 014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gecko: 7a9f2a248e57
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

I'm going to close this as worksforme. Please reopen if encountered again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.