[PTS][Certification]+CLIP AT command replied incorrect currupt string

RESOLVED FIXED in 2.2 S6 (20feb)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: shawnjohnjr, Assigned: brsun)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- AT: RING
	- FATAL ERROR (AT): +CLIP contains incorrect phone number: "0????S??int"  expected: "0939835820".  Check TSPX_phone_number
	- MTC received unexpected EXIT message from AT component
	- AT: Received +CLIP: "0????S??int",129




	132	Slave	46	AT+CLIP=1.	Enable CLI notofication			22	 00:00:00.000000	2015/2/5 下午 04:16:11.121000	
	134	Master	46	..OK..			Success	19	 00:00:00.010000	2015/2/5 下午 04:16:11.131000	
	135	Slave	46	AT+CCWA=1.	Enable call waiting notification			22	 00:00:00.000000	2015/2/5 下午 04:16:11.131000	
	137	Master	46	..OK..			Success	19	 00:00:00.010000	2015/2/5 下午 04:16:11.141000	
	138	Slave	46	AT+CMEE=1.	Enable Extended Audio Gateway Error Result Code			22	 00:00:00.000000	2015/2/5 下午 04:16:11.141000	
	140	Master	46	..OK..			Success	19	 00:00:00.010000	2015/2/5 下午 04:16:11.151000	
	143	Master	46	..+CIEV: 2,1..		Call Setup indicator's status report		26	 00:00:25.728000	2015/2/5 下午 04:16:36.879000	
	144	Master	46	..RING..		Incoming Call/Call progress indication		20	 00:00:00.005000	2015/2/5 下午 04:16:36.884000	
	145	Master	46	..+CLIP: "0....S..int",129..	+CLIP: "0黃S紫int",129			40	 00:00:00.000000	2015/2/5 下午 04:16:36.884000	
	147	Slave	46	ATA.		Answer mode		16	 00:00:00.025000	2015/2/5 下午 04:16:36.909000	
	149	Master	46	..OK..			Success	19	 00:00:00.015000	2015/2/5 下午 04:16:36.924000
We need to verify that clcc_response api correctly handle call number.
CLIP AT command was handle by bluedroid but we need to check that we pass the correct value to stack.
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
I can reproduce this bug on nexus5-l
It looks like |phone_state_change| |number| parameter is invalid.
This can blocked many PTS HFP phone call test cases because PTS will verify call numbers.
blocking-b2g: --- → 2.2?

Comment 5

4 years ago
Triage: blocking
Assignee: nobody → shuang
blocking-b2g: 2.2? → 2.2+
Assignee: shuang → nobody
We have investigated this bug. We dumped PDU sent from Gecko, nothing is wrong. Thanks for :brsun, we found the problem is from bluetoothd, 0-terminated string handling. We expected this will be resolved next week.
Transfer to :brsun, he found the solution. This blocker will be updated and resolved next week work day.
Assignee: nobody → brsun
Assignee

Comment 8

4 years ago
Attachment #8561204 - Flags: review?(tzimmermann)
Summary: [PTS]+CLIP AT command replied incorrect currupt string → [PTS][Certification]+CLIP AT command replied incorrect currupt string
Comment on attachment 8561204 [details] [review]
https://github.com/mozilla-b2g/platform_system_bluetoothd/pull/20

This looks good. Thank you for fixing this bug.
Attachment #8561204 - Flags: review?(tzimmermann) → review+
BTW, could you update the copyright message at the top as well? IIRC It says '2014  Mozilla...' and since you touched the file that should now be '2014-2015  Mozilla...'.
Assignee

Comment 11

4 years ago
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #10)
> BTW, could you update the copyright message at the top as well? IIRC It says
> '2014  Mozilla...' and since you touched the file that should now be
> '2014-2015  Mozilla...'.

Done.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Wait a second. There are now 3 commits. Two with code and a merge commit. Please remove the merge and just use a single commit for the fix.
Assignee

Comment 13

4 years ago
Comment on attachment 8561204 [details] [review]
https://github.com/mozilla-b2g/platform_system_bluetoothd/pull/20

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Regular PTS fails due to memory corruption.
Testing completed: Manual local testing.
Risk to taking this patch (and alternatives if risky): Low. This patch is very small and is just used to fix memory corruption.
String or UUID changes made by this patch: N/A.
Attachment #8561204 - Flags: approval-mozilla-b2g37?
Assignee

Updated

4 years ago
Attachment #8561204 - Flags: approval-mozilla-b2g37?
Assignee

Comment 14

4 years ago
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #12)
> Wait a second. There are now 3 commits. Two with code and a merge commit.
> Please remove the merge and just use a single commit for the fix.

Thanks. I'm going to handle this.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Assignee

Comment 15

4 years ago
Comment on attachment 8561204 [details] [review]
https://github.com/mozilla-b2g/platform_system_bluetoothd/pull/20

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Regular PTS fails due to memory corruption.
Testing completed: Manual local testing.
Risk to taking this patch (and alternatives if risky): Low. This patch is very small and is just used to fix memory corruption.
String or UUID changes made by this patch: N/A.
Attachment #8561204 - Flags: approval-mozilla-b2g37?
Just another nit for future patches: when you create patches for bluetoothd, please add the bug number to each commit summary; like for Gecko patches.
Assignee

Comment 17

4 years ago
Done.
Bruce, can you please recreate the pull request on the latest b2g/master?

The pull request for bug 1129257 messed up commit history with broken and merge commits. I fixed this up in current master.
Flags: needinfo?(brsun)
Assignee

Comment 19

4 years ago
Thanks Thomas, Ben, Shawn. A new PR has been created for review again.
Attachment #8561204 - Attachment is obsolete: true
Attachment #8561204 - Flags: approval-mozilla-b2g37?
Flags: needinfo?(brsun)
Attachment #8562515 - Flags: review?(tzimmermann)
waiting for master landing before getting to branch approval.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 22

4 years ago
Comment on attachment 8562515 [details] [review]
https://github.com/mozilla-b2g/platform_system_bluetoothd/pull/24

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Regular PTS fails due to memory corruption.
Testing completed: Manual local testing.
Risk to taking this patch (and alternatives if risky): Low. This patch is very small and is just used to fix memory corruption.
String or UUID changes made by this patch: N/A.
Attachment #8562515 - Flags: approval-mozilla-b2g37?
Target Milestone: --- → 2.2 S6 (20feb)
Attachment #8562515 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.