Closed Bug 1130077 Opened 5 years ago Closed 5 years ago

Intermittent test_mediaElementAudioSourceNodeCrossOrigin.html | Buffer is not silent as expected, for http://example.org:80/tests/dom/media/webaudio/test/corsServer.sjs (cors: anonymous) - got false, expected true

Categories

(Core :: Web Audio, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox37 --- fixed
firefox38 --- fixed
firefox39 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: padenot)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

19:44:43 INFO - 1286 INFO TEST-START | dom/media/webaudio/test/test_mediaElementAudioSourceNodeCrossOrigin.html
19:44:43 INFO - 1287 INFO TEST-PASS | dom/media/webaudio/test/test_mediaElementAudioSourceNodeCrossOrigin.html | Buffer is not silent as expected, for small-shot.ogg (cors: null)
19:44:43 INFO - 1288 INFO TEST-PASS | dom/media/webaudio/test/test_mediaElementAudioSourceNodeCrossOrigin.html | Buffer is silent as expected, for http://example.org:80/tests/dom/media/webaudio/test/small-shot.ogg (cors: null)
19:44:43 INFO - 1289 INFO TEST-UNEXPECTED-FAIL | dom/media/webaudio/test/test_mediaElementAudioSourceNodeCrossOrigin.html | Buffer is not silent as expected, for http://example.org:80/tests/dom/media/webaudio/test/corsServer.sjs (cors: anonymous) - got false, expected true
19:44:43 INFO - 1290 INFO MEMORY STAT vsize after test: 620675072
19:44:43 INFO - 1291 INFO MEMORY STAT residentFast after test: 165310464
19:44:43 INFO - 1292 INFO MEMORY STAT heapAllocated after test: 37444468
19:44:43 INFO - 1293 INFO TEST-OK | dom/media/webaudio/test/test_mediaElementAudioSourceNodeCrossOrigin.html | took 14042ms
Android 2.3 M10 is nearly permafail from this at the moment. Can you please help?
Flags: needinfo?(padenot)
ack, pushed to try with a possible fix, we'll see how it goes. Thanks for the heads up.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7800dfd42c35
Flags: needinfo?(padenot)
Attached file 9e8ce55e14cc
This seems to fix it, those machines are just too slow.
Assignee: nobody → padenot
Attachment #8573335 - Flags: review?(ehsan)
Attachment #8573335 - Flags: review?(ehsan) → review+
This seems to have not helped?
Flags: needinfo?(padenot)
I just checked, I don't see a single failure after my push, but I'll keep an eye out.
Flags: needinfo?(padenot)
https://hg.mozilla.org/mozilla-central/rev/d0b5cb4f657a
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
See Also: → 1169356
You need to log in before you can comment on or make changes to this bug.