Closed Bug 1130125 Opened 7 years ago Closed 6 years ago

extremetech.com does not redirect to mobile site due to pressly.com redirect

Categories

(Web Compatibility :: Mobile, defect)

Firefox 38
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bug.zilla, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all][contactready][clientsniff])

extremetech.com does not redirect to mobile site.
Works in Opera.
Product: Firefox → Firefox for Android
We can't control server behavior.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
I know. One for Evangelism.
So they're using a service called "Pressly" to do mobile detection (http://www.pressly.com/):

http://read.pressly.com/52960da3646f6d79c9030000/52961061646f6d79c9200000/redirect.js

There's a few problems in Pressly.Device.supportsMinimumRequirements:

> var isAncientMobileDevice = (OSversion.os === "Android" && versionNumber < 4);

This will be false because versionNumber is NaN, because it relies on having an Android version token in the UA string--which we don't have.

And their supportsNativeOverflowScroll function sniffs for the old Fennec UA string: 

> userAgent.match( /Fennec\/([0-9]+)/ ) && RegExp.$1 >= 4 ||

So return this.supportsNativeOverflowScroll() && !isAncientMobileDevice will be false. 

IMO, we should reach out to Pressly to get this fixed on their servers (which is where the redirect script is hosted anyways).
Summary: extremetech.com does not redirect to mobile site → extremetech.com does not redirect to mobile site due to pressly.com redirect
Whiteboard: [country-all][contactready]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-all][contactready] → [country-all][contactready][clientsniff]
It seems like a similar issue than Bug 971235
We seem we had a contact with Pressly in Bug 808572
Corban Brook still seems to work at Pressly. https://twitter.com/corban
Let's put him in needinfo for this bug. Hi Corban!

There is also Bug 971235.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Flags: needinfo?(corbanbrook)
We get a working mobile site on Firefox.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(corbanbrook)
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.