GA Requirements for hello.firefox.com

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: garethc, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
Based on the hello metrics doc, can we implement the following events on hello.firefox.com?

https://hello-onboarding.etherpad.mozilla.org/metrics-dashboard

Can we track the following behaviours on hello.firefox.com

1) On click of the 'Join the Conversation' CTA, please fire the following event:
ga('send', 'event', '/conversation/ interactions', 'button click', 'Join the Conversation');

2) On click of the 'Leave Conversation' CTA, please fire the following event:
ga('send', 'event', '/conversation/ interactions', 'button click', 'Leave Conversation');

3) On successful join of the conversation room (ie. after they accept the dialogue prompting him to share mic and cam)
ga('send', 'event', '/conversation/ interactions', 'success', 'Joined Conversation');

4) On click of support link at the top of the page:
ga('send', 'event', '/conversation/ interactions', 'Support link click', 'https://support.mozilla.org/kb/respond-firefox-hello-invitation-guest-mode');

5) On click of the privacy and terms of use links:
ga('send', 'event', '/conversation/ interactions', 'link click', href);

6) On click of the 'Get Firefox' button for unsupported browsers, please fire: 
ga('send', 'event', 'Firefox Downloads', 'download button click', 'Firefox Desktop');

It would also be good to update the link on download button with the following GA utm parameters: 
https://www.mozilla.org/firefox/new/?utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser

Thanks!
(Reporter)

Updated

4 years ago
Blocks: 1125217
(Reporter)

Comment 1

4 years ago
We also may want to anonymize IP Addresses for privacy reasons. The IP anonymization feature in Google Analytics sets the last octet of IPv4 user IP addresses and the last 80 bits of IPv6 addresses to zeros in memory shortly after being sent to the Google Analytics Collection Network.

More information on this is available here:
https://support.google.com/analytics/answer/2763052?hl=en

GA Implementation:
https://developers.google.com/analytics/devguides/collection/analyticsjs/advanced#anonymizeip

Add the following 
ga('set', 'anonymizeIp', true);
to the snippet:

<script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

      ga('create', 'UA-36116321-15', 'auto');
      ga('set', 'anonymizeIp', true);
      ga('send', 'pageview');
    </script>

We've implemented this specific feature on mozilla.org in bug: 
https://bugzilla.mozilla.org/show_bug.cgi?id=946705
:standard8 - any advice on where to start for adding these items on the LinkClicker?
Flags: needinfo?(standard8)

Comment 3

4 years ago
What you have here in the US field lists what we can track on the main room screen.
There are other screens that I think are worth tracking and currently we don't see the details of these pages in GA (not sure if it's because GA is not running on these screens or because of the GA configuration):
- "Link expired or invalid" screen
- "Room full" screen
- "Platform not supported" screen
- "Browser not supported" screen - desktop
- "Browser not supported" screen - android

There are also a couple of other buttons on the link clicker UI that we want to track usage of:
- Use of the retry button on the "Link expired or invalid" screen
- Use of the face mute button
- Use of the audio mute button
- Use of the "Get Firefox" on the "non supported browser" page when on Android

Does it make sense to add this to the scope here since this feels like related work?
(Reporter)

Comment 4

4 years ago
(In reply to Romain Testard [:RT] from comment #3)

> There are other screens that I think are worth tracking and currently we
> don't see the details of these pages in GA (not sure if it's because GA is
> not running on these screens or because of the GA configuration):
> - "Platform not supported" screen
> - "Browser not supported" screen - desktop
> - "Browser not supported" screen - android

If we know what platforms and browsers are not supported, we could create segments for these particular dimensions and apply them to reports to get this data. Else we could trigger an event when these screens appear like below on load of the page and display of message:

ga('send', 'event', '/conversation/ interactions', 'page load messages', 'Platform Not Supported');

For the Browser not supported message, you could segment the event by device category and just use:

ga('send', 'event', '/conversation/ interactions', 'page load messages', 'Browser Not Supported');


> - "Link expired or invalid" screen
> - "Room full" screen

For these two, we could probably just fire an event when these messages appear on page load. Something like:

ga('send', 'event', '/conversation/ interactions', 'page load messages', 'Link Expired or Invalid');
ga('send', 'event', '/conversation/ interactions', 'page load messages', 'Room Full');
  


> There are also a couple of other buttons on the link clicker UI that we want
> to track usage of:

> - Use of the retry button on the "Link expired or invalid" screen - on click
ga('send', 'event', '/conversation/ interactions', 'retry button click', 'Link Expired or Invalid');

> - Use of the face mute button - on click
ga('send', 'event', '/conversation/ interactions', 'face mute', status);

where status is:
mute
unmute

> - Use of the audio mute button - on click
ga('send', 'event', '/conversation/ interactions', 'audio mute', status);

where status is:
mute
unmute

> - Use of the "Get Firefox" on the "non supported browser" page when on
> Android

On click of 'Get Firefox': 
ga('send', 'event', 'Firefox Downloads', 'download button click', 'Firefox for Android');

Updated

4 years ago
Depends on: 1132222

Comment 5

4 years ago
(In reply to Gareth Cull [:garethc] from comment #4)
> (In reply to Romain Testard [:RT] from comment #3)
> 
> > There are other screens that I think are worth tracking and currently we
> > don't see the details of these pages in GA (not sure if it's because GA is
> > not running on these screens or because of the GA configuration):
> > - "Platform not supported" screen
> > - "Browser not supported" screen - desktop
> > - "Browser not supported" screen - android
> 
> If we know what platforms and browsers are not supported, we could create
> segments for these particular dimensions and apply them to reports to get
> this data. Else we could trigger an event when these screens appear like
> below on load of the page and display of message:
> 
> ga('send', 'event', '/conversation/ interactions', 'page load messages',
> 'Platform Not Supported');
> 
> For the Browser not supported message, you could segment the event by device
> category and just use:
> 
> ga('send', 'event', '/conversation/ interactions', 'page load messages',
> 'Browser Not Supported');
> 
> 
Actually we have platform (non supported platforms are iOS, Windows phone and Blackberry) and browser (non supported browsers on supported platforms are IE and Safari if we remain mainstream) reports within GA so probably no need for these events.
Thanks a lot for the details.

We typically implement Hello client bugs under the loop :: client category. 
I have created bug 1132222 to track this implementation - I have listed the requirements from your comments under the user story field, please feel free to amend.
No longer depends on: 1132222

Updated

4 years ago
Depends on: 1132222
I've just added comments to bug 1132222 about how I propose we do the implementation.
Flags: needinfo?(standard8)

Updated

3 years ago
Depends on: 1149793

Comment 7

3 years ago
I filed bug 1149793 to change the URL to the download as that is much easier and isn't a custom GA event. I would suggest we get that out the door soon so we can at least see referral traffic.

Updated

3 years ago
Blocks: 1195433

Comment 8

3 years ago
Gareth, can you please confirm that bug 1132222 addressed the requirements in this bug and therefore this can be closed?
Flags: needinfo?(garethcull.bugs)
(Reporter)

Comment 9

3 years ago
Confirmed. Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(garethcull.bugs)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.