Dolphin builds failing with lcd_hx8363_rgb_spi.c:449:36: error: 'struct panel_spec' has no member named 'display_height'

RESOLVED FIXED

Status

--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
One of the manifest updates today broke Dolphin builds:

https://treeherder.mozilla.org/logviewer.html#?job_id=1299429&repo=b2g-inbound

I'm closing Gaia and setting b2g-inbound to approval required.

18:29:03 INFO - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c: In function 'hx8363_set_window':
18:29:03 WARNING - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:315:13: warning: unused variable 'spi_read' [-Wunused-variable]
18:29:03 WARNING - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:314:18: warning: unused variable 'spi_send_data' [-Wunused-variable]
18:29:03 WARNING - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:313:17: warning: unused variable 'spi_send_cmd' [-Wunused-variable]
18:29:03 WARNING - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:312:12: warning: unused variable 'test_data' [-Wunused-variable]
18:29:03 INFO - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c: At top level:
18:29:03 WARNING - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:396:1: warning: initialization from incompatible pointer type [enabled by default]
18:29:03 WARNING - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:396:1: warning: (near initialization for 'lcd_hx8363_rgb_spi_operations.panel_readid') [enabled by default]
18:29:03 INFO - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c: In function 'lcd_hx8363_rgb_spi_init':
18:29:03 ERROR - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:449:36: error: 'struct panel_spec' has no member named 'display_height'
18:29:03 ERROR - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/kernel/drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.c:450:36: error: 'struct panel_spec' has no member named 'display_width'
18:29:03 ERROR - make[6]: *** [drivers/video/sprdfb/lcd/lcd_hx8363_rgb_spi.o] Error 1
18:29:03 INFO - CC drivers/video/sprdfb/spi/spi_simple_drv.o
18:29:03 ERROR - make[5]: *** [drivers/video/sprdfb/lcd] Error 2
18:29:03 INFO - make[5]: *** Waiting for unfinished jobs....
18:29:03 INFO - LD drivers/usb/gadget/usb_f_acm.o
18:29:03 INFO - arm-eabi-ld: /lib64/libz.so.1: no version information available (required by arm-eabi-ld)
18:29:03 INFO - CC drivers/usb/gadget/u_serial.o
18:29:03 INFO - CC drivers/usb/gadget/dwc_otg/dwc_otg_driver.o
18:29:03 INFO - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/prebuilts/gcc/linux-x86/arm/arm-eabi-4.7/bin/../lib/gcc/arm-eabi/4.7/../../../../arm-eabi/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/prebuilts/gcc/linux-x86/arm/arm-eabi-4.7/bin/../lib/gcc/arm-eabi/4.7/../../../../arm-eabi/bin/as)
18:29:03 INFO - /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/b2g_b2g-in_dph_dep-00000000000/build/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/as)
18:29:03 INFO - target thumb C++: libvideoeditorplayer <= frameworks/av/libvideoeditor/lvpp/VideoEditorSRC.cpp
As a temporary workaround, you can pin those repos to the last-good rev in the dolphin manifest.
https://github.com/mozilla-b2g/b2g-manifest/blob/master/dolphin.xml
Kai-Zhen, can you maybe help with this?
Flags: needinfo?(kli)
Component: Gaia::Build → General
Severity: major → blocker
Oh, the kernel/common change actually contained 2 new revs. This one looks a lot more suspicious:
http://git.mozilla.org/?p=external/sprd-aosp/kernel/common.git;a=commit;h=b1b29e61aa807caeed6e7237f09d1281a728bd6d
There is update in partner code. And this error is caused by this commit in u-boot: d5469d36f18fae90bca89a236c6ac23ed543c29c
Flags: needinfo?(kli)
Created attachment 8560246 [details] [diff] [review]
bug-1130255.patch

Ying, I think there is something wrong in 7715 kernel. Would you mind review and merge this patch into the kernel repo?
Flags: needinfo?(ying.xu)
Since apparently fixing broken builds isn't a high priority for anyone (leaving Gaia closed in the mean time), I've gone ahead and done the pinning I mentioned in comment 2.

Master: https://github.com/mozilla-b2g/b2g-manifest/commit/6e1c8e1f10da0b070d02fd0b25f1ab126f705b4e

Kai-Zhen, the commit above is going to need to be reverted before we will be able to pick up any further upstream updates from Spreadtrum.
Flags: needinfo?(kli)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #9)
> This time with proper syntax.
> https://github.com/mozilla-b2g/b2g-manifest/commit/
> 6a3df98732994ab8edf73e1672ca3b4b70089824

Ryan, Thanks! I'll revert this commit after partner fix this issue on upstream.
Flags: needinfo?(kli)
Dolphin builds are green again. I'll reopen as soon as the Gaia test bustage that was landed while the tree was closed is reverted. This bug should be left open until the upstream fix lands and the b2g-manifest workaround is reverted.
The issue is fixed and landed in upstream. The workaround is also reverted.
https://github.com/mozilla-b2g/b2g-manifest/commit/72ac585ff15662720cb1872af0cb917b98dd0a87
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ying.xu)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.