Closed Bug 1130403 Opened 7 years ago Closed 7 years ago

[B2G][Gallery] Photography takes a few seconds to be displayed

Categories

(Core :: ImageLib, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: yunito, Unassigned, NeedInfo)

References

()

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150202183609

Steps to reproduce:

1- Go to Menu
2- Open the Camera App
3- Take a Photograph with your Camera
4- Try to Open this Photography through the Camera App or Go to Gallery App and try to Open it


Actual results:

Photography takes a few seconds to be displayed (A Big Grey Image is displayed instead of the picture) 
Photography isn't displayed correctly until you do a double click on it


Expected results:

Photograph open instantly and the photography is displayed correctly

Device Information:

Gaia-Rev        94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko-Rev       
Build-ID        20150206010204
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
I can confirm this is occurring on the latest Flame 3.0 nightly build.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

This issue is NOT occurring on the latest Flame 2.2 nightly build.

Environmental Variables:
Device: Flame 2.2
Build ID: 20150206002505
Gaia: a52999ce7f783177deb17e267bf003a53e6fde06
Gecko: 01446d5231ef
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
Ever confirmed: true
Flags: needinfo?(pbylenga)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
[Blocking Requested - why for this release]:
Visual regression that fails smoke tests.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
:dfj, this is a smoketest blocker and the offending commit needs to be backed out asap.
Flags: needinfo?(dflanagan)
Changes for Bug 1129804 seem to have caused this issue.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150204221319
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: c1d6cde3d090
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150204232838
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: cec0b3b4403a
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: cec0b3b4403a

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: c1d6cde3d090

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c1d6cde3d090&tochange=cec0b3b4403a
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Flags: needinfo?(ktucker)
NI :seth to look at this and help investigate and make sure the backout happens if that's the culprit.
Flags: needinfo?(seth)
Flags: needinfo?(pbylenga)
Whiteboard: [backout-needed]
(In reply to Parul Mathur [:pragmatic] from comment #5)
> :dfj, this is a smoketest blocker and the offending commit needs to be
> backed out asap.

Looks like it was a gecko change that broke this. I don't know how to do backouts for gecko, so I'll leave this to Seth.

Seth: I haven't had a chance to look at the breakage at all, but if you're going to need concurrent gaia patches before you land your gecko changes let's coordinate that next week.  It looks like turning on decode-on-draw has also broken thumbnails in the video app.
Flags: needinfo?(dflanagan)
Thumbnails in the video app bug: Bug 1130584
https://bugzilla.mozilla.org/show_bug.cgi?id=1129804 is backed-out so removing the whiteboard.
Whiteboard: [backout-needed]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Setting resolved fixed according to Comment 10.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Jayme can you verify this on the next available nightly?
Flags: needinfo?(jmercado)
Keywords: qaurgent
Depends on: 1130707
Verified fixed on the latest Nightly Flame 3.0 build.

Results: Gallery images displayed immediately.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado) → needinfo?(ktucker)
Duplicate of this bug: 1130422
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Moving the bug to the component where the regression came from.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Gallery → ImageLib
Product: Firefox OS → Core
You need to log in before you can comment on or make changes to this bug.