[Calendar][RTL] swipe direction should be mirrored on month view for RTL locales

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mmedeiros, Assigned: mmedeiros)

Tracking

unspecified
2.2 S6 (20feb)
x86
macOS
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

after discussing this through email we decided that it will be better for the UX if all the swipes inside the calendar follow the same pattern.

if touch starts at the right of the screen and ends at the left it should move to the previous month.

this is important since on the Week view the dates are displayed as RTL and it would look weird if swipe was on the same direction as LTR.
Assignee: nobody → mmedeiros
Status: NEW → ASSIGNED
Attachment #8560583 - Flags: review?(gaye)
feature-b2g: --- → 2.2+
Priority: -- → P2

Updated

4 years ago
Flags: in-moztrap-
Comment on attachment 8560583 [details] [review]
[PullReq] millermedeiros:1130479-rtl-swipe-month-view to mozilla-b2g:master

?r :jrburke since :gaye will be working on automation for the next couple weeks.
Attachment #8560583 - Flags: review?(gaye) → review?(jrburke)
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8560583 [details] [review]
[PullReq] millermedeiros:1130479-rtl-swipe-month-view to mozilla-b2g:master

Code works as expected on flame device. I had a nit question in the pull request around the var name, but fine with whatever choice of name you feel works for the code.
Attachment #8560583 - Flags: review?(jrburke) → review+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8560583 [details] [review]
[PullReq] millermedeiros:1130479-rtl-swipe-month-view to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: swipe direction on month view will be inconsistent with day/week views for RTL
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Attachment #8560583 - Flags: approval-gaia-v2.2?
Attachment #8560583 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 7

4 years ago
This issue has been verified successfully on Flame 2.2/3.0.
Attachment:Verify_RTL_Weekview.mp4

Flame 3.0:

Build ID               20150215010209
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.043133
Firmware Date          Sun Feb 15 04:31:43 EST 2015
Bootloader             L1TC000118D0

Flame 2.2:

Build ID               20150215002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040852
Firmware Date          Sun Feb 15 04:09:03 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]

Comment 8

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15879/
Flags: in-moztrap- → in-moztrap+
You need to log in before you can comment on or make changes to this bug.