Closed Bug 113067 Opened 18 years ago Closed 18 years ago

tr bgcolor covers vertical cellspacing and previous rowspan

Categories

(Core :: Layout: Tables, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 4510

People

(Reporter: maniak, Assigned: karnaze)

Details

Here's some (ugly) test code :

---

<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html 
     PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/2001/WD-xhtml1-20011004/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
<head>
  <title>blah</title>
</head>

<body>

<table width="100%" border="0" cellspacing="1" cellpadding="3">
  <tr bgcolor="red">
    <td rowspan="2" width="100" align="center">blah</td>
    <td colspan="3" align="center">blah</td>
  </tr>
  <tr bgcolor="green">
    <td width="100" align="center">blah</td>
    <td width="100" align="center">blah</td>
    <td width="100" align="center">blah</td>
  </tr>
  <tr bgcolor="blue">
    <td width="100">blah</td>
    <td width="100" bgcolor="yellow" align="center">blah</td>
    <td width="100" bgcolor="pink" align="center">blah</td>
    <td rowspan="2" width="100" align="center">blah<br />blah</td>
  </tr>
  <tr bgcolor="orange"><td colspan="3">blah</td></tr>
</table>

</body>
</html>

---

Each cell should be separated by 1 pixel, but only rows are. Vertical spacing is
covered by the row bgcolor.
Likewise, when a column spans 2 rows, the bgcolor of the 2nd row still shows, as
is the horizontal spacing.

Without the DTD, everything is displayed correctly.
> Likewise, when a column spans 2 rows, the bgcolor of the 2nd row still shows,

This is correct behavior in standards mode.  The reason you do not see it
without the DTD is that then we are in backwards-compatible "quirks" rendering mode.

> Vertical spacing is covered by the row bgcolor.

Bug 4510.  The spec is self-contradictory as to what should happen here, it seems.


*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
 Verified dupe of Bug# 4510
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.