[Mac][10.10] Window controls missing in full screen mode

VERIFIED FIXED in Firefox 37

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: phlsa, Assigned: mstange)

Tracking

({regression})

Trunk
mozilla38
All
Mac OS X
regression
Points:
---
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox36 ?, firefox37+ verified, firefox38+ verified)

Details

Attachments

(3 attachments)

Created attachment 8560890 [details]
Nightly vs Release

The current Nightly builds are missing the window controls when a window is in full screen mode on OS X 10.10. See attachment for a comparison of Release and Nightly channels.
Flags: firefox-backlog+
(Assignee)

Updated

4 years ago
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Component: Shell Integration → Widget: Cocoa
Product: Firefox → Core
Hardware: x86_64 → All
Version: Firefox 38 → Trunk
(Assignee)

Comment 1

4 years ago
I think this is a regression from bug 1120917.
Blocks: 1120917
(Assignee)

Comment 2

4 years ago
Created attachment 8561208 [details] [diff] [review]
patch
Attachment #8561208 - Flags: review?(smichaud)
Comment on attachment 8561208 [details] [diff] [review]
patch

Looks good to me.
Attachment #8561208 - Flags: review?(smichaud) → review+
https://hg.mozilla.org/mozilla-central/rev/8d85dce8ab6e
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38

Updated

4 years ago
Iteration: --- → 38.3 - 23 Feb
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: catalin.varga
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1130733
(Assignee)

Comment 7

4 years ago
Created attachment 8563183 [details] [diff] [review]
aurora patch

We have a very similar problem on aurora, which is fixed by this patch: bug 1130733
Aurora doesn't have the patch for bug 1120917, that's why on Aurora the buttons are only slightly shifted instead of invisible.

Approval Request Comment
[Feature/regressing bug #]: Mac OS 10.10
[User impact if declined]: shifted window controls in full screen mode
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: very low
[String/UUID change made/needed]: none
Attachment #8563183 - Flags: approval-mozilla-aurora?
(In reply to Markus Stange [:mstange] from comment #7)
> We have a very similar problem on aurora, which is fixed by this patch: bug
> 1130733
> Aurora doesn't have the patch for bug 1120917, that's why on Aurora the
> buttons are only slightly shifted instead of invisible.
> 
> Approval Request Comment
> [Feature/regressing bug #]: Mac OS 10.10

Many fixes for OSX 10.10 shipped in 34. Bug 1120917 was fixed in 38 and bug 1130733 was resolved as a dup of this bug. Do you know that bug that introduced the issue? Does this affect 36?
status-firefox36: --- → ?
status-firefox37: --- → affected
tracking-firefox37: --- → +
tracking-firefox38: --- → +
Flags: needinfo?(mstange)
Comment on attachment 8563183 [details] [diff] [review]
aurora patch

This is a branch specific patch for Aurora that has a different fix than that required for Nightly. We'll need to verify the patch on Aurora. Aurora+
Attachment #8563183 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed using:

FF 38 BUILD ID: 20150211222327
Mac Os x 10.10
status-firefox38: fixed → verified
(Assignee)

Comment 12

4 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #8)
> (In reply to Markus Stange [:mstange] from comment #7)
> > We have a very similar problem on aurora, which is fixed by this patch: bug
> > 1130733
> > Aurora doesn't have the patch for bug 1120917, that's why on Aurora the
> > buttons are only slightly shifted instead of invisible.
> > 
> > Approval Request Comment
> > [Feature/regressing bug #]: Mac OS 10.10
> 
> Many fixes for OSX 10.10 shipped in 34. Bug 1120917 was fixed in 38 and bug
> 1130733 was resolved as a dup of this bug. Do you know that bug that
> introduced the issue? Does this affect 36?

I was assuming that we have always had the offset bug on 10.10, ever since we started shifting the buttons in the regular Firefox window (bug 851652). But now that I've tried to find a regression range, I noticed that I can't actually reproduce the shifted button problem, in any build. It's possible that the reporter of bug 1130733 only hit it due to a lucky coincidence. In any case, the patch is the right way to fix it in the cases that it does occur.

(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #9)
> This is a branch specific patch for Aurora that has a different fix than
> that required for Nightly. We'll need to verify the patch on Aurora. Aurora+

Well, the fix is the same (adding a " && !([self styleMask] & NSFullScreenWindowMask)"), just the context has changed.
Flags: needinfo?(mstange)
Reproduced using Nightly 38.0a1 2015-02-07.
Verified as fixed with Firefox 37 beta 1 under Mac OS X 10.10.
Status: RESOLVED → VERIFIED
status-firefox37: fixed → verified
You need to log in before you can comment on or make changes to this bug.