TypeError: node.parentNode is null at: app://callscreen.gaiamobile.org/gaia_build_defer_index.js line: 186

RESOLVED DUPLICATE of bug 1106637

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1106637
3 years ago
3 years ago

People

(Reporter: Anshul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caf priority: p2][CR 793157])

(Reporter)

Description

3 years ago
I am seeing the following exception in the logs when running voice call related unit test scripts. This only reproduces during automation and there is no specific steps that cause this issue.

TypeError: node.parentNode is null at: app://callscreen.gaiamobile.org/gaia_build_defer_index.js line: 186
(Reporter)

Updated

3 years ago
Blocks: 1063044
No longer blocks: 1094121
Hi Anshul, although you mention that "there is no specific steps that cause the issue" :) , would you be so kind to provide any other value information you may consider of interest as a second thought, please? :p For example, which version or branch are you running the automation tests with.

I have just tried with v2.2 (Gecko-d125eaa.Gaia-e827781) and I am not able to reproduce the issue in all the scenarios I have tried (1-to-1 calls, call waiting, conference calls). In fact, it should be already fixed thanks to the patch for bug 1106637 which landed in master and v2.2.

Need-infoing Gabrielle just to have him on the loop and also in case he is able to provide us with any clue or hint about the issue :)

Thank you very much ;)
Flags: needinfo?(gsvelto)
Flags: needinfo?(anshulj)

Updated

3 years ago
Whiteboard: [CR 793157]

Updated

3 years ago
Whiteboard: [CR 793157] → [caf priority: p2][CR 793157]
triage: please re-verify as this seems to have been already addressed in a newer build. Please renom if it still happens with newest build.
blocking-b2g: 2.2? → ---
I agree with German's assessment that this must have been dealt with already in bug 1106637.
Flags: needinfo?(gsvelto)
(Reporter)

Comment 4

3 years ago
Hello Germán, I am seeing the issue on v2.2. I am waiting for bug 1106637 to be uplifted to our internal builds. I will update this bug once we have the results available.
Flags: needinfo?(anshulj)
Please reopen if this issue still appears after you have a build containing bug 1106637.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106637

Updated

3 years ago
No longer blocks: 1063044
You need to log in before you can comment on or make changes to this bug.