[RTL][Clock]Text of 3 options at the bottom is shown in English for about 1 sec firstly.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: mcav)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted video video.MP4
[1.Description]:
[RTL][Clock]When you launch Clock app, 3 options at the bottom are shown in English for about 1 sec at first.
See attachment:video.MP4

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Go to Clock app for the first time.
2. Observe the text of 3 options at the bottom.

[3.Expected Result]: 
2. The text of 3 options at the bottom should be shown in Arabic.

[4.Actual Result]: 
3. Text of 3 options at the bottom is shown in English for about 1 sec at first.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150208002500
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.035623
Firmware Date          Sun Feb  8 03:56:34 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
feature-b2g: --- → 2.2+
Priority: -- → P2
Assignee

Updated

4 years ago
Assignee: nobody → m
Status: NEW → ASSIGNED
Assignee

Updated

4 years ago
Target Milestone: --- → 2.2 S6 (20feb)
Assignee

Comment 2

4 years ago
Comment on attachment 8563551 [details] [review]
[gaia] mcav:clock-tabs-rtl > mozilla-b2g:master

Apparently loading Alameda right before </body> makes l10n unhappy, and instead "<script defer"-ing it like we do all the other scripts resolves this problem.

My guess is that the alameda load (and hence all the app's scripts) used to get queued up first (since it was at the end of </body>, the page has to fetch that synchronously), causing it to take a while before l10n had a chance to get things going.
Attachment #8563551 - Flags: review?(mmedeiros)
Attachment #8563551 - Flags: review?(mmedeiros) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/28184

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 5

4 years ago
Comment on attachment 8563551 [details] [review]
[gaia] mcav:clock-tabs-rtl > mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #): none

[User impact] if declined:
Users will see the clock tabs in English for one second even if their language is set to something else.

[Testing completed]: manual verification

[Risk to taking this patch] (and alternatives if risky): low

[String changes made]: none
Attachment #8563551 - Flags: approval-gaia-v2.2?
Attachment #8563551 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master.

Result: The English text does not appear when launching the app.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

============================================
Unable to verify on Flame 2.2 as bug 1134649 is still blocking 2.2. leaving verifyme for 2.2 verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Depends on: 1134649
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15233/
Flags: in-moztrap+
Reporter

Comment 9

4 years ago
Posted video verify_v2.2.MP4
This issue has been verified successfully on Flame v2.2, when you set system language as Arabic and launch Clock app, 3 options at the bottom are shown in Arabic.
See attachment:verify_v2.2.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.