All users were logged out of Bugzilla on October 13th, 2018

Ctrl + Right Arrow doesn't work on line end on *some* websites

RESOLVED DUPLICATE of bug 1153237

Status

()

RESOLVED DUPLICATE of bug 1153237
4 years ago
3 years ago

People

(Reporter: borekb, Unassigned)

Tracking

38 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150202183609

Steps to reproduce:

Enter some a text in a textarea in Gmail and Twitter, place your cursor near the end of the text (like 3-4 words before it) and press Ctrl + right arrow multiple times.


Actual results:

Go to next word works except for the last word which is not skipped. For instance, when the cursor is here:

this is some |text

Pressing Ctrl+Right arrow does nothing while it should do this:

this is some text|


Expected results:

Ctrl + right arrow should allow me to skip right till the end of the string.
(Reporter)

Comment 1

4 years ago
This happens only on some websites, e.g. in Gmail or when composing new Tweet, but e.g. not here in Bugzilla. Also, this only started happening in FF 36 beta (not sure which one, I've been encountering it for the last couple of weeks), I've never experienced it before.
Confirmed on twitter.com on 38.0a1 (2015-02-09) Win 7
Status: UNCONFIRMED → NEW
Component: Untriaged → Keyboard: Navigation
Ever confirmed: true
Product: Firefox → Core
Version: 36 Branch → 38 Branch
(Reporter)

Comment 3

4 years ago
Any news on this? The bug is quite unpleasant when working with the text in Firefox, especially composing emails.

I'm also wondering what it can technically be because some textareas work just fine (like this one in BugZilla, fields on StackOverflow etc.). But I consistently get the misbehavior in Gmail and on Twitter.
(Reporter)

Comment 4

3 years ago
Still observable in 41.0b5.

Comment 5

3 years ago
Thanks a lot for the report! Some work on this issue has already been done in bug 1153237
Actually, your note (that firefox 36 was the first affected version) was quite useful.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153237
You need to log in before you can comment on or make changes to this bug.