Closed Bug 1131026 Opened 5 years ago Closed 5 years ago
IText Input Processor .init(For Tests) should be renamed to ns IText Input Processor .begin Input Transaction(For Init)
No description provided.
I agree with your idea. The names are a little bit long, but it's not so problem. Similarly, "notify-detached" should be renamed to "notify-end-input-transaction".
Comment on attachment 8561377 [details] [diff] [review] Patch >+ * initForTest(), first. See beginInputTransaction() for more detail of this. s/initForTest/beginInputTransactionForTests/ So it is not clear to me whether we need this, if init() just worked as expected. But either way.
(In reply to Olli Pettay [:smaug] from comment #2) > Comment on attachment 8561377 [details] [diff] [review] > Patch > > >+ * initForTest(), first. See beginInputTransaction() for more detail of this. > s/initForTest/beginInputTransactionForTests/ Oops, thanks! (I used replace of my editor but the comment misspelled...) > So it is not clear to me whether we need this, if init() just worked as > expected. > But either way. The method name, begin input transaction, sounds better to me because: * the name is clearer what they do. * the notification name is also clearer, especially the relation between the notification and these methods. * it's better name to grep the method ;-) (init() is defined by a lot of classes!) I'll land it, but if you have additional objections, I'll back it out.
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.