If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow zealous GC to be triggered by off-thread allocations

RESOLVED DUPLICATE of bug 1131233

Status

()

Core
JavaScript: GC
RESOLVED DUPLICATE of bug 1131233
3 years ago
3 years ago

People

(Reporter: terrence, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
It seems that in many tests, we'll simply skip performing any zealous GC while the background thread is allocating: this seems suboptimal. These triggers cannot do the GC inline, but they can at least schedule a GC at the next safe spot which hopefully might make these more likely while the parse thread is present.

We should probably also skip these if we are in a more-deterministic run mode, but I think that is probably true of all our background triggers, which I don't think we're suppressing at the moment.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131233
You need to log in before you can comment on or make changes to this bug.