Closed Bug 1131243 Opened 5 years ago Closed 5 years ago

Private browsing notification in urlbar

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

We should add a notification in the urlbar when the user is in a private browser.

Visual spec: https://mozilla.app.box.com/s/fanxlaw7ilhm0walsod6hy4ps47v9eh3
feature-b2g: --- → 2.2+
Assignee: nobody → kgrandon
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8566610 [details] [review]
[gaia] KevinGrandon:bug_1131243_rocketbar_icon_private_browsing > mozilla-b2g:master

Mike - Can I get an initial review here? Still need to swap the assets out for the properly colored ones I think, but will try to do that before landing. Thanks!
Attachment #8566610 - Flags: review?(mhenretty)
Comment on attachment 8566610 [details] [review]
[gaia] KevinGrandon:bug_1131243_rocketbar_icon_private_browsing > mozilla-b2g:master

Found one small issue in RTL mode. Should be an easy fix, but I want to play around with it a little with it fixed before r+.
Attachment #8566610 - Flags: review?(mhenretty)
Comment on attachment 8566610 [details] [review]
[gaia] KevinGrandon:bug_1131243_rocketbar_icon_private_browsing > mozilla-b2g:master

Nice catch! Anything else here?
Attachment #8566610 - Flags: review?(mhenretty)
Comment on attachment 8566610 [details] [review]
[gaia] KevinGrandon:bug_1131243_rocketbar_icon_private_browsing > mozilla-b2g:master

Looking good! Let's land this sucka!!
Attachment #8566610 - Flags: review?(mhenretty) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8566610 [details] [review]
[gaia] KevinGrandon:bug_1131243_rocketbar_icon_private_browsing > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Private Browsing feature.

[User impact] if declined:
Missing urlbar icon when in private mode, dimished UX.

[Testing completed]:
Manually tested.

[Risk to taking this patch] (and alternatives if risky):
Low risk, just some url bar enhancements.

[String changes made]: none.
Attachment #8566610 - Flags: approval-gaia-v2.2?
Attachment #8566610 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual results:  There is a private browsing icon to the left of the url bar in private tabs.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150227010229
Gaia: 7512026a377271a0cade12d70846557f0bc7781c
Gecko: c7968255c1ea
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150227002521
Gaia: eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gecko: c8a38dcfbebc
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.