If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MediaDecoderStateMachine should handle negative time

RESOLVED DUPLICATE of bug 1179110

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1179110
3 years ago
2 years ago

People

(Reporter: jya, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Spawned from bug 1114805 comment 9

Currently, we assert if we attempt to perform any operations on a negative time value (in particular seek).

start and end time position are initially set to -1 which means "no value/not set".

There's no guarantee that a media won't have a negative start or end value. The only guarantee is that the duration is positive.

We should handle this case, and don't assume that a time can't be negative
(Reporter)

Updated

3 years ago
Depends on: 1137100
(Reporter)

Comment 1

2 years ago
bug 1179110 will fix this issue.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179110
You need to log in before you can comment on or make changes to this bug.