[Search] Clearing search term in Rocketbar leaves History and Default Search headers on screen

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: bzumwalt, Assigned: apastor)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted image Screenshot
Description:
When user searches for a term in Rocketbar then clears search term by pressing "X" button, the Default search header (e.g. "Google Search", "Yahoo Search", etc.) remains although no search results appear. If the search term brought up browsing history results, the "History" header will remain as well. Furthermore, if there were any Marketplace results, any remaining headers will be vertically offset by the amount of space that was previously taken up by the Marketplace results.

Repro Steps:
1) Update a Flame to 20150209010211
2) Tap Rocketbar and enter a search term
3) Tap "X" button on Rocketbar to clear search term

Actual:
Default search and History headers remain visible in search results area.

Expected:
Search result area is blank in an empty state.

Environmental Variables:
Device: Flame 3.0 Master
Build ID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 3/3, 100%
See attached: screenshot
(Reporter)

Comment 1

4 years ago
Issue DOES occur on Flame 2.2

Default search header does not appear in pre-3.0 builds, but the "History" header still appears and displays same behavior.

Device: Flame 2.2
Build ID: 20150209002504
Gaia: e827781324cbde91d2434b388f5dead3303a85ee
Gecko: 0552759956d3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Unable to check 2.1 due to lack of headers/different design in rocketbar search.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Hermes, can you take a look at this and weigh in on the severity of this issue?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(hcheng)
According to the figures in UX spec, empty state should not have anything but only blank and the input bar.

UX spec: https://mozilla.app.box.com/s/44utizl9oz4eupyu3fuu/1/2545278347/24162816989/1
blocking-b2g: --- → 2.2?
Flags: needinfo?(hcheng) → needinfo?(bfrancis)
Ben, could you take a look?
Whiteboard: [systemsfe]
Team confirms this is a blocker
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Updated

4 years ago
Attachment #8570431 - Flags: review?(kgrandon)
Comment on attachment 8570431 [details] [review]
[gaia] albertopq:1131408-headers-search > mozilla-b2g:master

This looks great to me. Thanks for taking it!
Flags: needinfo?(bfrancis)
Attachment #8570431 - Flags: review?(kgrandon) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Could you please uplift to v2.2? Thanks.
Flags: needinfo?(apastor)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8570431 [details] [review]
[gaia] albertopq:1131408-headers-search > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): - 
[User impact] if declined: Different behavior when clearing the search input through the keyboard or through the X button. The search headers remain visible on the second case
[Testing completed]: Added unit tests.
[Risk to taking this patch] (and alternatives if risky): Low risk. 1 liner with tests.
[String changes made]: -
Flags: needinfo?(apastor)
Attachment #8570431 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8570431 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  The search results are cleared when pressing the x button.
	
Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.