YouTube videos take a long time to start in HTML5 player, CORS errors in console

RESOLVED DUPLICATE of bug 1135078

Status

()

defect
RESOLVED DUPLICATE of bug 1135078
4 years ago
4 years ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks 1 bug)

38 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
YouTube videos occasionally don't start in the HTML5 player until 10+ seconds after the page has loaded. Reloading the page doesn't help. Interestingly, IE has the same issue but Chrome works properly.

The Firefox Error Console shows a dozen blocked CORS requests:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://r1---sn-8xgn5uxa-quhe.googlevideo.com/videoplayback?lmt=1392660351511505&expire=1423555806&sparams=clen%2Cdur%2Cgir%2Cid%2Cip%2Cipbits%2Citag%2Ckeepalive%2Clmt%2Cmime%2Cmm%2Cms%2Cmv%2Cpl%2Crequiressl%2Csource%2Cupn%2Cexpire&upn=n4zufndWp18&sver=3&fexp=907263%2C927622%2C930676%2C9405989%2C9406664%2C943917%2C947225%2C948124%2C952302%2C952605%2C952612%2C952901%2C955301%2C957201%2C959701&mm=31&gir=yes&signature=<..snip..>&id=<..snip..>&dur=67.168&mt=1423533997&mv=u&source=youtube&ms=au&clen=947064&ip=<..snip..>&keepalive=yes&itag=160&requiressl=yes&mime=video%2Fmp4&key=yt5&ipbits=0&pl=48&cpn=GkZ7Tx-tPm8xIcpP&alr=yes&ratebypass=yes&c=WEB&cver=html5&range=0-871. (Reason: CORS request failed).

I've seen this issue on both e10s and non-e10s Nightly 38 profiles, but it is intermittent.
Reporter

Updated

4 years ago
Summary: YouTube videos take a long time to start in the HTML5 player → YouTube videos take a long time to start in HTML5 player, CORS errors in console
The problem is server side. I'm told that the CORS errors are in fact server errors that are missing the appropriate CORS headers. IE and Firefox play MP4 and Chrome plays WebM and therefore is accessing different URLs.
Blocks: MSE
We've made YouTube aware of the issue, there's not much else we can do. The issue is with their server configuratinos.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
(In reply to Ralph Giles (:rillian) from comment #2)
> We've made YouTube aware of the issue, there's not much else we can do. The
> issue is with their server configuratinos.

I'm not sure that's true. Chrome doesn't have these issues, and I don't think WebM vs. MP4 is enough to explain that away. We'll need to replicate this and debug some more.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
The issue is definitely a problem with YouTube but we are tracking it in bug 1135078. I've been discussing with the networking guys how we can get a better diagnosis.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1135078
You need to log in before you can comment on or make changes to this bug.