Closed Bug 1131444 Opened 5 years ago Closed 5 years ago

B2G: Assertion failure: work_queue_.empty(), at message_loop.cc:410

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox39 fixed)

RESOLVED FIXED
2.2 S8 (20mar)
Tracking Status
firefox39 --- fixed

People

(Reporter: kechen, Assigned: kershaw)

References

Details

Attachments

(1 file, 1 obsolete file)

I am working on another bug, Bug 1097479. And ran into this assertion error by running the mochitest test case I added :

  >Assertion failure: work_queue_.empty(),

  https://treeherder.mozilla.org/logviewer.html#?job_id=4522817&repo=try

When finishing the test and closing it, the assertion error happened. There is already another bug relative to this error Bug 986113. It said that is caused by the destroyed timing. But I have no idea to fix this.

This bug can be reproduced by running mochitest on nested oop and close it.
e.g, ./mach mochitest-plain --nested ./dom/base/test/test_Image_constructor.html
Hello Bill, I saw you had a discussion in bug 1090921,if you are available, are there any advice to this error. Thank you.
Flags: needinfo?(wmccloskey)
I've set some breakpoints to track the error, however the assertion error never happened when I doing so. This might be the timing issue like bug 986113 mentioned. I'll keep tracing it.
Blocks: nested-oop
I found this is due to that PContentBridge is not closed when the content process is ended. After adding some code to close PContentBridge when got "content-child-shutdown", I don't see this failure anymore.
A patch will be uploaded later.
Assignee: nobody → kechang
Kyle, could you please take a look at this patch?
I think it makes sense to close PContentBridge channel when the content process is going to shutdown. Thanks.
Attachment #8574006 - Flags: review?(khuey)
Comment on attachment 8574006 [details] [diff] [review]
Close PContentBridge when content process is ended

Review of attachment 8574006 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8574006 - Flags: review?(khuey) → review+
Since this bug is fixed, clear the needinfo request.
Flags: needinfo?(wmccloskey)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/cb931e2210e1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S8 (20mar)
See Also: → 1170939
You need to log in before you can comment on or make changes to this bug.