Don't add transceive req into RequestQueue in NfcMessageHandler.

RESOLVED FIXED in Firefox 38, Firefox OS v2.2

Status

Firefox OS
NFC
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: allstars, Assigned: allstars)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [p=1])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Transceive Req shouldn't be added into mPendingReqQueue in NfcMessageHandler.cpp.
(Assignee)

Comment 1

3 years ago
Created attachment 8561907 [details] [diff] [review]
Patch.
Attachment #8561907 - Flags: review?(dlee)
(Assignee)

Updated

3 years ago
blocking-b2g: --- → 2.2?

Updated

3 years ago
Attachment #8561907 - Flags: review?(dlee) → review+
(Assignee)

Comment 2

3 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/bc064f894ded
Whiteboard: [p=1]
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Comment 3

3 years ago
Comment on attachment 8561907 [details] [diff] [review]
Patch.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1109456

User impact if declined: 
NFC operations will fail after calling IsoDep.transceive.

Testing completed:
Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=79cc8eda92e2

Risk to taking this patch (and alternatives if risky):
No.

String or UUID changes made by this patch:
No
Attachment #8561907 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/bc064f894ded
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+

Updated

3 years ago
Attachment #8561907 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6d93ecd5d3e7
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox36: --- → wontfix
status-firefox37: --- → wontfix
You need to log in before you can comment on or make changes to this bug.