If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

YouTube html5 video no playback

VERIFIED WORKSFORME

Status

()

Core
Audio/Video
--
major
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: chaosfreedom1220, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8561962 [details]
Nightly64 raw 21015.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150209030204

Steps to reproduce:

Try to play HTML5 video on YouTube. No playback at all. Tried new profile using both the "refresh nightly" button on about:support as well as the old fashion deletion of profile from root folder. Firefox 35 and 36 work perfectly. IE does as well. 


Actual results:

No playback at all. Zero audio or video no matter how long I wait. 


Expected results:

Audio and video playback of HTML5 video on YouTube.
(Reporter)

Updated

3 years ago
Hardware: x86 → x86_64
(Reporter)

Comment 1

3 years ago
Created attachment 8561964 [details]
nightly64 21015.txt

Comment 2

3 years ago
I have this problem too, with Firefox 35.0.1 on MacOSX 10.9.5. I have the latest Flash (16.0.0.305). I can play flash videos from other web sites, and I can play Youtube videos in Safari, but I can't play Youtube videos in Firefox. (I think the problem started before 35.0.1.) All I see is the stylized "f" and it is not clickable. (I'll attach a screen shot.)

Comment 3

3 years ago
Created attachment 8562221 [details]
youtube.problem.png

This is all I get from videos on Youtube with Firefox. I used to be able to click on the "f" and the video would load and play. (I can do this on other websites that have Adobe Flash content.) But beginning sometime before 35.0.1 the "f" became unclickable.
Please test it with a clean fresh new Firefox profile without any addons and plugins.
Flags: needinfo?(steve.chessin)
Flags: needinfo?(chaosfreedom1220)
(Reporter)

Comment 5

3 years ago
I have with no luck
Flags: needinfo?(chaosfreedom1220)

Comment 6

3 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #4)
> Please test it with a clean fresh new Firefox profile without any addons and
> plugins.

How do I do that?
Flags: needinfo?(BernesB)
In simplest way go to:
C:\Users\YOUR_ACCOUNT_NAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOME_SIGNS.default
and rename "SOME_SIGNS.default" to ex. "SOME_SIGNS.default-BACKUP" so you can revert it if it still be happening in clean fresh new profile
Flags: needinfo?(BernesB)
Looks as if you are both using the Flashblock addon? In installed it on my 10.9.5 machine and I am still able to click the "F" button and the video plays fine.
(Reporter)

Comment 9

3 years ago
Im not using Flashblock at all. I am using Ad Block Plus and its pop-up blocker extension.
So please test it with a clean fresh new Firefox profile without any addons and plugins,
and report back if it still happens or not.
Flags: needinfo?(chaosfreedom1220)
(Reporter)

Comment 11

3 years ago
As I stated above in comment #5, I already have done that. I reinstalled them after testing. I think me and the other guy are having different issues as any older youtube videos that are still Flash-based works. It is strictly HTML5 failing for me.
Flags: needinfo?(chaosfreedom1220)
(Reporter)

Comment 12

3 years ago
Every update for Nightly I try at minimum using the "restart nightly" button in about:support every time hoping for a change.
Blocks: 1083588
Severity: normal → major
Component: Untriaged → Video/Audio
Product: Firefox → Core
Version: Firefox 38 → Trunk
chaosfreedom: Can you please try disabling DXVA:

Set the pref "media.windows-media-foundation.use-dxva" to "false"in about:config and then restart.
(Reporter)

Comment 14

3 years ago
Did that. No luck. Im going to add two attachments that are snips of a video. One of what it does, and the other of the stats YouTube gives for the video.
(Reporter)

Comment 15

3 years ago
Created attachment 8562993 [details]
Capture.JPG

Capture of HTML5 video constantly buffering, never starting.
(Reporter)

Comment 16

3 years ago
Created attachment 8562997 [details]
Capture2.JPG

Stats given by YouTube from the video. As displayed some of the video was parsed with a few frames decoded but nothing else. This is after letting the video try to load for ~5 minutes.
Please update your GPUs drivers to the latest ones and post graphics section info from about:support if it still happens.
e10s is enabled as I see, it still happens if disabled?
disabling HW Acc helps in any way?

If you can, you may try finding a regression range as it will be needed probably next to get this bug fixed faster:
- first try mozilla-central builds:
https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
- next, deeper in mozilla-inbound builds:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/

Before this, try Firefox stable, Beta and Aurora to make it sure it's really a regression.
Flags: needinfo?(chaosfreedom1220)
(Reporter)

Comment 18

3 years ago
35.0.1 works
Flags: needinfo?(chaosfreedom1220)
Status: UNCONFIRMED → NEW
status-firefox35: --- → unaffected
status-firefox36: --- → ?
status-firefox37: --- → ?
status-firefox38: --- → affected
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 19

3 years ago
So far I have gone back to Jan 19th. Totally dead here. 

Just so its here.

Nvidia drivers: 347.52
(Reporter)

Comment 20

3 years ago
I don't understand why, but I decided to see if this was directly a Windows issue so I reformatted my entire system and now it works. So maybe it was something with Nightly communicating with the kernel or graphics drivers through Windows 7 that can corrupt the process? I guess we can call this resolved, but I suspect maybe some others could be effected by this if it's something that can happen due to odd software to OS communication issue. Could just be one of those random glitches Windows has that cannot be explained. Who knows.
(Reporter)

Comment 21

3 years ago
Ill switch this to resolved, I guess.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
status-firefox35: unaffected → ---
status-firefox36: ? → ---
status-firefox37: ? → ---
status-firefox38: affected → ---
Flags: needinfo?(steve.chessin)
Keywords: regression, regressionwindow-wanted
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.