[Flame][First Time Experience]SIM 2 PIN page's "<" button can't be used in FTU.

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: mancas)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 wontfix, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(6 attachments, 1 obsolete attachment)

Reporter

Description

4 years ago
[1.Description]:
[Flame][2.1 & 2.2][First Time Experience]If user insert a sim card (PIN enable) to phone's slot 2, and then launch FTU via flash rom or develop menu, he will find SIM 2 PIN page's "<" button can't be used.
Attachment:video.mp4&logcat_0517.txt
Found time:05:17

[2.Testing Steps]: 
Prerequisites: Insert a sim card (PIN enable) to phone's slot 2.
1.Launch FTU via flash rom or develop menu.
2.Navigate to PIN page.
3.Tap "<" button.

[3.Expected Result]: 
3.Device will back to previous page.

[4.Actual Result]: 
3.Device has no response.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0

Flame 2.1 build:
Build ID               20150209001212
Gaia Revision          4a14bb118d55f3d15293c2ff55b7f29f9b0bfcdb
Gaia Date              2015-02-06 20:37:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6cbe28d0bb8c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.035242
Firmware Date          Mon Feb  9 03:52:53 EST 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Posted video video.mp4
Reporter

Comment 2

4 years ago
Posted file logcat_0517.txt
Hi Elie, Does this reproduce on master?

Set 2.2? for inconsistency with SIM1 behavior.
blocking-b2g: --- → 2.2?
Flags: needinfo?(zikui.yang)
(In reply to Eric Chang [:ericcc] [:echang] from comment #3)
> Hi Elie, Does this reproduce on master?
> 
> Set 2.2? for inconsistency with SIM1 behavior.

Hi Eric,
This issue be verified exist on latest flame 3.0 build.
If you insert SIM card to slot1 "<" button can be used normally.

Flame 3.0 build:
Build ID               20150210010523
Gaia Revision          0cf517083f7eb5fc269e1236edba50534f65e3cd
Gaia Date              2015-02-09 18:21:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2cb22c058add
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150210.050217
Firmware Date          Tue Feb 10 05:02:28 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(echang)
Reporter

Updated

4 years ago
Flags: needinfo?(zikui.yang) → needinfo?
Reporter

Updated

4 years ago
Flags: needinfo?
clear ni as we already nominated this.
Flags: needinfo?(echang)
(In reply to Elie from comment #0)
> [1.Description]:
> [Flame][2.1 & 2.2][First Time Experience]If user insert a sim card (PIN
> enable) to phone's slot 2, and then launch FTU via flash rom or develop
> menu, he will find SIM 2 PIN page's "<" button can't be used.
> Attachment:video.mp4&logcat_0517.txt
> Found time:05:17
> 
> [2.Testing Steps]: 
> Prerequisites: Insert a sim card (PIN enable) to phone's slot 2.
> 1.Launch FTU via flash rom or develop menu.

FTU via flash rom means a fresh profile where the FTU was never completed before?
Whiteboard: [systemsfe]
Reporter

Comment 7

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #6)
> (In reply to Elie from comment #0)
> > [1.Description]:
> > [Flame][2.1 & 2.2][First Time Experience]If user insert a sim card (PIN
> > enable) to phone's slot 2, and then launch FTU via flash rom or develop
> > menu, he will find SIM 2 PIN page's "<" button can't be used.
> > Attachment:video.mp4&logcat_0517.txt
> > Found time:05:17
> > 
> > [2.Testing Steps]: 
> > Prerequisites: Insert a sim card (PIN enable) to phone's slot 2.
> > 1.Launch FTU via flash rom or develop menu.
> 
> FTU via flash rom means a fresh profile where the FTU was never completed
> before?
FTU via flash rom does not mean a fresh profile where the FTU was never completed before.
Just tell you that: there are 2 ways to enter FTU "flash rom and start device" or "Enter Settings->Developer->Launch first time use" .
Flags: needinfo?(anygregor)
Broken functionality
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(anygregor)
Assignee

Updated

4 years ago
Assignee: nobody → b.mcb
Posted file Proposed patch (obsolete) —
Fernando could you review the patch?

Thanks a lot =)
Attachment #8563966 - Flags: review?(fernando.campo)
Comment on attachment 8563966 [details] [review]
Proposed patch

sorry for the delay.
just tested on device, and it works nicely, just some nits on the code and adding one more test for both SIM cards PIN protected.

Also, I discovered that when we put the correct pin for sim1, when we are shown the pin screen for sim 2, the back button doesn't appear, but I guess that it's a different bug.
Attachment #8563966 - Flags: review?(fernando.campo)
Comment on attachment 8563965 [details] [review]
[gaia] mancas:bug1131509 > mozilla-b2g:master

I've added the unit tests needed to check all the possible scenarios.

Can you take a look?

Thanks =)
Attachment #8563965 - Flags: review?(fernando.campo)
Comment on attachment 8563965 [details] [review]
[gaia] mancas:bug1131509 > mozilla-b2g:master

All good! thanks
Attachment #8563965 - Flags: review?(fernando.campo) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Posted video video_v3.0.MP4
This issue has been verified successfully on Flame 3.0
STR:
Prerequisites: Insert a sim card (PIN enable) to phone's slot 2.
1.Launch FTU via reset device.
2.Navigate to PIN page.
3.Tap "<" button.
**Device backs to previous page.
See attachment:video_v3.0.MP4
Rate:0/3

Flame 3.0 build:
Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880
QA Whiteboard: [MGSEI-Triage+]
Hi Fernando, could we uplift to 2.2, thanks.
Flags: needinfo?(fernando.campo)
Posted file 2.2 uplift request
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: user won't be able to go back from the SIM2 PIN screen
[Testing completed]: tested on device with dual sim plus unit tests
[Risk to taking this patch] (and alternatives if risky): low risk (one line change)
[String changes made]:
Attachment #8563966 - Attachment is obsolete: true
Flags: needinfo?(fernando.campo)
Attachment #8573876 - Flags: approval-gaia-v2.2?
Attachment #8573876 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on latest Flame v2.2.
See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5.

Flame 2.2 build:
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040546
Firmware Date          Wed Mar 11 04:05:57 EDT 2015
Bootloader             L1TC000118D0

Comment 21

4 years ago
Hi Hermes,
This issue still exists on latest build of Flame 2.1 by STR in comment 0. Could you please help to confirm whether this issue will be fixed in 2.1 build or not? Many thanks :)
Flags: needinfo?(hcheng)
Mike, is this going to be fixed in 2.1?
Flags: needinfo?(hcheng) → needinfo?(mlien)
No, v2.1 won't take this patch, change branch to wontfix
Status: RESOLVED → VERIFIED
Flags: needinfo?(mlien)
You need to log in before you can comment on or make changes to this bug.