Closed Bug 1131604 Opened 5 years ago Closed 2 years ago

Yahoo toolbar preferences are broken and several elements are missing from the toolbar

Categories

(WebExtensions :: General, defect)

x86_64
All
defect
Not set

Tracking

(firefox36+ wontfix, firefox37 affected, firefox38 affected)

RESOLVED INVALID
Tracking Status
firefox36 + wontfix
firefox37 --- affected
firefox38 --- affected

People

(Reporter: cornel_ionce, Unassigned)

References

Details

(Keywords: regression)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:36.0) Gecko/20100101 Firefox/36.0		
Firefox 36 beta 8, Build ID: 20150209164123

STR:
1. Open Firefox;
2. Install the yahoo toolbar extension (https://addons.mozilla.org/en-US/firefox/addon/yahoo-toolbar/);
3. After the add-on is installed, go to about:addons -> extensions;
4. Select "preferences" for the Yahoo toolbar.

Expected results:
The toolbar settings is opened in another page.

Actual results:
A blank square is displayed in the middle of the page and the settings are not displayed.
Screenshot: http://i.imgur.com/I19kdWe.jpg

Notes:
This issue also reproduces on Latest Nightly and Latest Aurora.
It is a regression, as it does not reproduce in Firefox 35.0.1.

I will investigate further on and will update with the regression range.
[Tracking Requested - why for this release]: Regression from Firefox 36.0a1 that affects Yahoo toolbar users

The same behavior as on Mac OSX is encounter when accessing Preferences under Ubuntu 14.04 32 bit.

On Windows (XP 32-bit and 8.1 64-bit), on the other hand, the browser freezes when "Options" button is selected from about:addons page.

This is a Firefox 36 regression:
Last good revision: 62990ec7ad78 (2014-11-05)
First bad revision: 2114ef80f6ae (2014-11-06)
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=62990ec7ad78&tochange=2114ef80f6ae

Starting then, several elements are missing from the toolbar too, please see: http://i.imgur.com/SJrLxqG.png
OS: Mac OS X → All
Summary: Yahoo toolbar preferences are broken → Yahoo toolbar preferences are broken and several elements are missing from the toolbar
Mozilla inbound shows bug 611388 as the culprit.

Last good revision: 3dc4a906df95
First bad revision: a9a7f16c817b
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3dc4a906df95&tochange=a9a7f16c817b
Depends on: 611388
OK, I guess that was expected with the "const" change.

Jorge, could you get in touch with the developer? FYI, I notified Kev Needham but he is offline.

By the way, any chance this affects other addons?
Flags: needinfo?(jorge)
So, that's a pretty old version of the toolbar, is the same bug present on the version at https://toolbar.yahoo.com/ ?
I could mark the versions as incompatible, but it sounds like it's not completely broken. If the problem is just the preferences panel, I think we can ignore that. The AMO version has relatively low usage, so it's not a big concern for us. It'd be great if we got a new version that can pass review, but that probably requires a lot of work on their side.
Flags: needinfo?(jorge)
(In reply to Mike Connor [:mconnor] from comment #4)
> So, that's a pretty old version of the toolbar, is the same bug present on
> the version at https://toolbar.yahoo.com/ ?

Yes, this bug is also present in that version.
Not tracking anymore. We contacted them, there is not much we can do here
Kevin, is this something you would like to follow up on? It doesn't sound like we ever got a response from Yahoo on the toolbar addon.
Flags: needinfo?(kev)
There's some ongoing discussions about their new add-on, but most users shouldn't be affected.
Flags: needinfo?(kev)
(In reply to Mike Connor [:mconnor] from comment #9)
> There's some ongoing discussions about their new add-on, but most users
> shouldn't be affected.

Mike, I imagine this can be closed given the demise of legacy add-ons on release channels?
Flags: needinfo?(mconnor)
Component: Add-ons Manager → Add-ons
Product: Toolkit → Tech Evangelism
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
This is regarding third-party software we don't manage or control. We've notified the developer of the changes to Firefox, and have not received any responses. Given the age of this bug, the changes to add-ons, and the lack of response from Yahoo I think it's fair to close this bug.
Flags: needinfo?(mconnor)
(sorry, should be marked invalid, as the changes requested are the responsibility of the developer)
Resolution: WONTFIX → INVALID
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.