marking things as solved needs to be more visual

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: atopal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Page 21: Marking questions as solved is just written down as text. We need something more visual.
This screen has been modified, please take a look the updated visual spec. Thanks!
File link: https://bugzilla.mozilla.org/attachment.cgi?id=8563918

Updated

4 years ago
Blocks: 1137145
The mockups and spec have been updated, please refer to page 18 & page 24.
Updated spec link: https://bugzilla.mozilla.org/attachment.cgi?id=8571866
Flags: needinfo?(anthony)
Redirecting to Kadir because I'm not sure what more visual meant here.
Flags: needinfo?(anthony)

Updated

4 years ago
Flags: needinfo?(a.topal)
(Reporter)

Comment 4

4 years ago
I might be missing something here, but it still seems like there is only text to indicate that you have to click to solve the question. The issue is that we'd display that text on every single reply by a contributor. In a quick back and forth it would take an inordinate amount of space and focus.
Flags: needinfo?(a.topal)

Updated

4 years ago
Flags: needinfo?(hhuang)
Created attachment 8579110 [details]
Improved visual.png

Sorry I found there are incorrect mockups in the visual spec. Attached the modified mockups here, and I will update the spec by today. Let me know if any question.
Flags: needinfo?(hhuang)

Updated

4 years ago
Flags: needinfo?(a.topal)
The visual spec has been updated, please refer to page 18 and 24 in the latest file. 
v1.7 spec https://bugzilla.mozilla.org/attachment.cgi?id=8579268

Let me know if any question. Thanks!
(Reporter)

Comment 7

4 years ago
Thanks, Helen!
Flags: needinfo?(a.topal)

Comment 8

4 years ago
Hi Helen,

I had a look and i still feel that "Mark question as resolved" is too long and doesn't look visual enough.. Also, I would like to shorten it or rephrase it to something like "This (re)solved my question". 
What do you think?
Flags: needinfo?(hhuang)
Created attachment 8582255 [details]
MarkQuestionAsResolved.png

Hi Hermina, 

I agree with rephrasing the sentence to make it simpler and more friendly. That's a good point.

For the visual issue, I think the current design problem probably is the contrast, so I try to make the clickable area darker, please refer to the attachment. I've considered another way that using pill shape button, but it might be too strong and will occupy too much space, therefore, using background color is a way which is cleaner and simpler. Feel free to let me know if any idea.
Flags: needinfo?(hhuang) → needinfo?(hcondei)

Comment 10

4 years ago
I've commented on a different bug on this as well. It looks good, let's try it like this for now. Thanks!
Flags: needinfo?(hcondei)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.