Closed Bug 1131761 Opened 5 years ago Closed 5 years ago

[Search] Changing search engine in search app does not automatically update search results/suggestions

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected, b2g-master affected)

VERIFIED DUPLICATE of bug 1131966
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: bzumwalt, Unassigned)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Attached image Screenshot
Description:
When user has a search term in the rocketbar, tapping the search engine header and changing the search engine shows same search suggestions/search results as the previous search engine selected. User must re-search same term to get updated search results listed for new engine.

Repro Steps:
1) Update a Flame to 20150210010523
2) Tap rocketbar and enter search term
3) Select search engine header and change search engine
4) Press OK and observe that search results in rocketbar have not changed
5) Tap home button
6) Select rocketbar

Actual:
Search results do not automatically update after changing search engine in search app. User must re-search.

Expected:
Search results automatically update after changing search engine in search app.

Environmental Variables:
Device: Flame 3.0 Master
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 3/3, 100%
See attached: screenshot & logcat
Attached file Logcat
Issue DOES occur on Flame 2.2

Search results do not automatically update after changing search engine in search app. User must re-search.

Device: Flame 2.2
Build ID: 20150210002516
Gaia: b30c8e4303595a0fcb5b640d673cf8503b954701
Gecko: 3e9fa4e70a1b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Unable to test on 2.1 as changing search engine within search app is not a feature in that build.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Hermes, can you take a look at this please? Should these search results update automatically when the user changes the search provider?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(hcheng)
This is a dupe
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131966
thanks Dale, clear ni for me.
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.