[RTL][Share Activity] Text overlapping share activity icons

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: jfkthame)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(4 attachments)

Description:
The user will see text overlapping app icons when they are viewing any share activity screen.

Prerequisite: Have language set to Arabic

Repro Steps:
1) Update a Flame to 20150210010523
2) Long tap on home screen
3) Tap on the middle option (change wallpaper)


Actual:
The share activity screen has text overlapping on the icons


Expected:
There is no text overlap

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Screenshot
This issue does NOT occur on Flame 2.2

The text is properly placed to the left of the app icons in share activity menus

Environmental Variables:
Device: Flame 2.2
BuildID: 20150210002516
Gaia: b30c8e4303595a0fcb5b640d673cf8503b954701
Gecko: 3e9fa4e70a1b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Blocks: system-rtl
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Noticeable regression for RTL support.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [rtl-impact]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
Cause: Bug 1130231 seems to have caused this issue.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150209063429
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: c13e7799a147
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150209064732
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 70a1847bdc20
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 70a1847bdc20

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: c13e7799a147

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c13e7799a147&tochange=70a1847bdc20
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Jonathan, can you take a look at this please? Looks like this might have been caused by the work done on bug 1130231
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker) → needinfo?(jfkthame)
Assignee

Comment 5

4 years ago
This is probably the same issue as bug 1132194. Extracting a minimal testcase would help greatly in determining what's happening here.

Michael, can you possibly help with a testcase?
Flags: needinfo?(jfkthame) → needinfo?(mhenretty)
Assignee

Comment 7

4 years ago
Never mind, I think I found this one: the CSS in action_menu_extended.css that adds padding to leave space for the icon is not direction-aware. Fixing bug 1130231 made the padding correctly stay on the left, as specified.
Assignee

Updated

4 years ago
Flags: needinfo?(mhenretty)
Assignee

Updated

4 years ago
Attachment #8563381 - Flags: review?(mhenretty)
Comment on attachment 8563381 [details] [review]
[gaia] jfkthame:patch-5 > mozilla-b2g:master

Thanks for helping out!
Attachment #8563381 - Flags: review?(mhenretty) → review+
feature-b2g: --- → 2.2+
Priority: -- → P1

Updated

4 years ago
Assignee: nobody → jfkthame
blocking-b2g: 3.0? → ---
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Comment on attachment 8563381 [details] [review]
[gaia] jfkthame:patch-5 > mozilla-b2g:master

Ah duh, I'm not a system peer. Kevin, could you stamp this?
Attachment #8563381 - Flags: review?(kgrandon)
Comment on attachment 8563381 [details] [review]
[gaia] jfkthame:patch-5 > mozilla-b2g:master

Yup!
Attachment #8563381 - Flags: review?(kgrandon) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8563381 [details] [review]
[gaia] jfkthame:patch-5 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 1130231

[User impact] if declined:
RTL is broken.

[Testing completed]:
Manually tested.

[Risk to taking this patch] (and alternatives if risky):
Low risk, css only change.

[String changes made]:none.
Attachment #8563381 - Flags: approval-gaia-v2.2?

Comment 14

4 years ago
Hi William,
    This issue has been verified failed on Flame3.0. Could you help to check it? Thanks.
Reproduce rate:5/5.
Attachment:Verify_RTL_Fail.png.

Flame 3.0 build:

Build ID               20150215010209
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.043133
Firmware Date          Sun Feb 15 04:31:43 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(whsu)

Comment 15

4 years ago
Posted image Verify_RTL_Fail.png
(In reply to Coler from comment #14)
> Hi William,
>     This issue has been verified failed on Flame3.0. Could you help to check
> it? Thanks.
> Reproduce rate:5/5.
> Attachment:Verify_RTL_Fail.png.
> 
> Flame 3.0 build:
> 
> Build ID               20150215010209
> Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
> Gaia Date              2015-02-13 13:13:27
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
> Gecko Version          38.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150215.043133
> Firmware Date          Sun Feb 15 04:31:43 EST 2015
> Bootloader             L1TC000118D0

Hi, Coler,

We merged this patch 2 days ago. 
But, the gaia revision you verified is 3 days ago.
- https://github.com/mozilla-b2g/gaia/commit/f0b93e0668ef9565bd6f050b15b4f794d59feb65

Could we verify it later?
Thanks.
Flags: needinfo?(whsu) → needinfo?(liuyong)
Attachment #8563381 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master.

Result: Icons and text do not overlap on share activity menu.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
====================
Leaving verifyme for 2.2 uplift and verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+] → [QAnalyst-Triage?][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionverifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact], [MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(ktucker)

Comment 19

4 years ago
According to Comment 17, clear my NI.
Flags: needinfo?(liuyong)

Comment 20

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15861/
Flags: in-moztrap+

Comment 21

4 years ago
Posted image verify.png
This issue has been verified successfully on Flame 2.2, the text is not overlaped with icon.
See attachment:verify.png
Rate:0/5

Flame 2.2 build:
Build ID               20150226162510
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1be266320634
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.195624
Firmware Date          Thu Feb 26 19:56:35 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
You need to log in before you can comment on or make changes to this bug.