Closed Bug 1131832 Opened 5 years ago Closed 4 years ago

Youtube pauses after the first few seconds of playback without MSE

Categories

(Core :: Audio/Video: Playback, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox37 - wontfix
firefox38 - affected
firefox39 - affected

People

(Reporter: jrmuizel, Assigned: cajbir)

Details

(Keywords: regression)

On this video with h264 and dash disabled I get a few seconds of playback and then it spins the throbber to get more data. This happens consistently.
https://www.youtube.com/watch?v=CCkqPIWZF1s
Is this with nightly?

The video plays start to end fine for me with the 2015-01-31 nightly.
Blocks: MSE
Fine with latest nightly too.
Yes, Nightly 20150210030231. I imagine it might be somewhat connection speed related. Did you disable MSE when trying to reproduce?
what does Right-Click on video, stats for nerd says?
Flags: needinfo?(jmuizelaar)
It was quite a challenge to get youtube to let me copy this out...

Video ID:	CCkqPIWZF1s
Dimensions:	640 x 360 * 2
Resolution:	1280 x 720
Volume:	59%
Stream Type:	https
CPN:	ozcAx6QyOSakpXh3
Mime Type:	video/mp4; codecs="avc1.64001F, mp4a.40.2"
DASH:	no (22)
Bandwidth:	0 Kbps
Decoded Frames	Dropped Frames	Parsed Frames	Presented Frames
15	-	19	4
Video Bytes Decoded	Audio Bytes Decoded	Painted Frames	Paint Delay
-	-	6	-
Flags: needinfo?(jmuizelaar)
Working fine here. Selected 720p quality, started playback. MP4/H264 ... It takes a little while to start while it buffers a bit and then it plays.

This is on a macbook air with 10.10.2, latest nightly
To be clear, Jeff appears to be describing non-MSE video going in and out of buffering mode on a slow connection.
Keywords: regression
Priority: -- → P1
Flags: needinfo?(mozillamarcia.knous)
I did test this on my MBP using the latest nightly build with MSE disabled using about:config.

I played the video 3-4 times using my home wifi network with 720p. A few times I did get the spinner, but it did not happen for me consistently while the video was playing.

I can perhaps try this on a slower connection to see if I get consistent results.
Flags: needinfo?(mozillamarcia.knous)
Bobby - can you look into this one?
Flags: needinfo?(bobbyholley)
This does not seem particularly actionable, and I don't see why it blocks MSE.
Flags: needinfo?(bobbyholley)
there's something dodgy happening when buffering (ref bug 1131884) ; in particular the 30s time
(In reply to Jean-Yves Avenard [:jya] from comment #11)
> there's something dodgy happening when buffering (ref bug 1131884) ; in
> particular the 30s time

30s is just the amount of time we stay in buffering when the state machine thinks that buffering is the right thing to do - as a fail safe, we forcibly switch to DECODING after 30s no matter what, which generally helps us get unstuck in these situations.
the issue here is that it doesn't appear to realise we now have enough data buffered and wait 30s regardless.

In the bug I was referring to, I can see the video being entirely buffered after a couple of seconds, yet it wait 30s to resume playback.
This looks like a duplicate of bug 1131884 which has a patch up.
This doesn't appear to be the same as bug 1131884. With the fix for that applied I get the stuttery buffering on this video still.

There are some MPEG4Extractor errors on initial decoding, I'm not sure if that's part of the cause.
Status: NEW → ASSIGNED
Assignee: nobody → cajbir.bugzilla
If we want this fix in 37, we're going to need a relatively safe fix by Thu, Mar 19.
I reviewed this bug with Anthony today. The issue is not that significant with MSE now and doesn't impact platforms that still use Flash. I'm dropping tracking and marking this bug as wontfix for 37.
Component: Audio/Video → Audio/Video: Playback
No longer blocks: MSE
I'm assuming this is fixed with the read vs seek change
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.