Re-enable TestKeyActions.test_open_in_new_window_shortcut for e10s

RESOLVED DUPLICATE of bug 1096488

Status

RESOLVED DUPLICATE of bug 1096488
4 years ago
4 years ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 1 bug, {pi-marionette-task})

unspecified
x86
Mac OS X
pi-marionette-task
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
This was disabled when bug 1047603 landed because it perma-oranged with e10s. We should figure out how to fix this test to work with e10s.
Component: Firefox UI Tests → Marionette
Product: Mozilla QA → Testing
Version: Version 3 → unspecified
This is bad timing in that test and a variation on the issue that needed a workaround in bug 1047603. The test waits to see two chrome window handles, then tries to switch to the new one without waiting for a content window to talk to in the new chrome window. I can change the wait to wait for two content windows, but then the window handle is invalidated by the switch from non-remote to remote in that browser when the test page is loaded.

So we try to apply the workaround from bug 1047603 to every window, not just the first one, or we can block this on marionette knowing how to deal with changes in remoteness.
Blocks: 984139
tracking-e10s: --- → +
Keywords: ateam-marionette-task
Unskipping is fixed with bug 1096488.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096488
You need to log in before you can comment on or make changes to this bug.