Properly handle segment discontinuity

RESOLVED DUPLICATE of bug 1141333

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1141333
4 years ago
4 years ago

People

(Reporter: jya, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
We have three conditions that we need to properly handle:

1- No data available, need to wait
2- No data available, it's a discontinuity skip to the next available
3- No data available, it's end of stream. Finish playback

Currently, we only properly handle 3).

When we reach the end of the buffered range and we search for the next available reader to provide us with more data, we perform a search across all segments and use the best one available.
That search is done using a fuzz factor of 125ms.

However, should the file be poorly muxed, it can happen that the time gap between two segments is slightly greater. We this happens we wait for more data.

As no data is ever going to come, video playback stall (and often either just audio or just video plays)

We need to be able to identify between condition 1 and condition 2 properly, ignore the discontinuity and continue playback.
Reporter

Updated

4 years ago
Blocks: 1131487
Reporter

Updated

4 years ago
No longer blocks: 1131487

Updated

4 years ago
Priority: -- → P2
Reporter

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1141333
You need to log in before you can comment on or make changes to this bug.