Initialise _iccChannelCalback in RilContentHelper.js

RESOLVED FIXED in Firefox 38

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tauzen, Assigned: tauzen)

Tracking

unspecified
2.2 S6 (20feb)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

While running SecureElement code (Bug 879861) on master I've got "this._iccChannelCallback is undefined" error. _iccChannelCallback was introduced in Bug 1081789, and the original version of the patch actually initialised it. The initialisation line was probably lost while rebasing to master. It needs to be added back for SE API to work properly.
Assignee

Updated

4 years ago
Blocks: 879861
blocking-b2g: --- → 2.2?
Depends on: 1081789
Hi Edgar, since you reviewed the patches in Bug 1081789 could you take a look a this? From my perspective this looks like a regression caused by rebase.
Attachment #8562758 - Flags: review?(echen)
Assignee: nobody → kmioduszewski
triage: blocker as it's blocking bug 879861 (SE)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8562758 [details] [diff] [review]
0001-Bug-1132007-Initialise-_iccChannelCalback-in-RilCont.patch

Review of attachment 8562758 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with comment addressed. Thank you, kmioduszewski!

Please also help to add `_iccChannelCallback: null` right before `_addIccChannelCallback: function(requestId, channelCb) {` [1], just like what |_iccListeners| does [2].

[1] https://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/RILContentHelper.js#596
[2] https://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/RILContentHelper.js#561
Attachment #8562758 - Flags: review?(echen) → review+
Thanks Edgar! I've updated the patch as you requested. Once I'll get a green try build I'll request checkin.
Attachment #8562758 - Attachment is obsolete: true
Attachment #8563340 - Flags: review+
https://treeherder.mozilla.org/#/jobs?repo=try&revision=171f0e2fdaa2

I think there's a global problem with OSX builds, apart from that everything seems to be ok.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2b9834775157
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8563340 [details] [diff] [review]
(v1.1) 0001-Bug-1132007-Initialise-_iccChannelCalback-in-RilCont.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1132007, see more details in comment 0
User impact if declined:
Broken Secure Element API feature - Bug 879861  
Testing completed: on device testing complete
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #8563340 - Flags: approval-mozilla-b2g37?
Attachment #8563340 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.