Closed Bug 1132241 Opened 5 years ago Closed 5 years ago

Crash [@ nsINode::GetFirstElementChild() ]

Categories

(Core :: General, defect, critical)

x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: johnp, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, crashreportid)

Crash Data

Reporting a bug mentioned on mozillazine[1]. I'm not sure which component to put this (layout/widget win32/layout:view), so for the moment this is filed in General.

Crash signature: bp-d2fe7129-b8c1-43aa-b916-e0b692150211

Reports:

https://crash-stats.mozilla.com/report/list?product=Firefox&range_unit=days&range_value=7&signature=nsINode%3A%3AGetFirstElementChild%28%29#tab-reports

STR according to the mozillazine poster:

"try to copy url or settings-advance-data choice tab = crash"

[1] http://forums.mozillazine.org/viewtopic.php?p=14019641#p14019641
Crash Signature: [@ nsINode::GetFirstElementChild() ]
Keywords: crash
Here's a "nicer" stack trace than the one linked above: bp-fc74b52c-9bf1-49f4-80f7-e708a2150211
This only on Win10 Preview builds ?  No crash here on Win7 x64.
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #3)
> This only on Win10 Preview builds ?  No crash here on Win7 x64.

Just tried in win8.1 update 3
Happens most of the times(3 out of 10)
[Tracking Requested - why for this release]:
(In reply to ElevenReds from comment #8)
> uninstalled it but still crashing for me(new profile nothing else)
> 
> https://crash-stats.mozilla.com/report/index/99e6ffe4-c30a-4dd3-8aca-
> ddd8d2150214
> 
> https://crash-stats.mozilla.com/report/index/1862f156-e4c2-448a-a0ce-
> f65d92150214

It's no a clean fresh new profile without any addons and plugins...
as I can clearly see addons in Extension tab in crashlog report...
(In reply to Virtual_ManPL [:Virtual] from comment #10)
> (In reply to ElevenReds from comment #8)
> > uninstalled it but still crashing for me(new profile nothing else)
> > 
> > https://crash-stats.mozilla.com/report/index/99e6ffe4-c30a-4dd3-8aca-
> > ddd8d2150214
> > 
> > https://crash-stats.mozilla.com/report/index/1862f156-e4c2-448a-a0ce-
> > f65d92150214
> 
> It's no a clean fresh new profile without any addons and plugins...
> as I can clearly see addons in Extension tab in crashlog report...

Sorry pasted the wron crash log, was crashing so mixed it up.
But i think FDM is un-installed it that but so it's not Free Download Manager issue.
Can add the crash log again tomorrow only.
This one w/o Free download manger uninstalled i thinks
So no its a Firefox issue.


https://crash-stats.mozilla.com/report/index/849c631a-9106-4b58-bf76-756a52150214#metadata

will try to get crash report from new profile again tomorrow.
Thank you very much.
Now crashlog report is clean and not cluttered by additional info from addons and plugins.

Looks like it's mainly the Windows 10 issue, so it should be blocking bug #1077146
Blocks: windows-10
Status: UNCONFIRMED → NEW
Ever confirmed: true
The STR in comment 0 are vague (for example there are several ways to copy urls).

ElevenReds: Can you please share a detailed list of your steps to reproduce the crash?
Normally this

https://bugzilla.mozilla.org/show_bug.cgi?id=1132241#c0

If you want anything else let me know.
Flags: needinfo?(bezaleel360)
(In reply to ElevenReds from comment #15)
> Normally this
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1132241#c0
> 
> If you want anything else let me know.

Can someone upload a screencast of what is triggering this? Is this still crashing on current nightly with no add-ons? I just tried to reproduce by copying URLs / going to the options, and neither crashed for me (win10 VM).
Flags: needinfo?(johnp)
Flags: needinfo?(bezaleel360)
Sorry, but I just reported the bug on bugzilla for the original reporter on mozillazine. I'm not even sure if I was able to reproduce it at that time, but I assume not, because I originally set the bugs status to Unconfirmed. I hope ElevenReds has more info. But fwiw, I just re-read the thread and at least one comment indicates, that this was not reproducible with a 64-bit build[1].

[1] http://forums.mozillazine.org/viewtopic.php?p=14023553#p14023553
Flags: needinfo?(johnp)
Going to mark this as WFM bordering on incomplete - if people can still reproduce then please add more detailed steps before reopening. The socorro data here implies this crash died with 38, and has 0 reports from win10 in the last 28 days, so it's unlikely this is really relevant for our win10 tracking.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(bezaleel360)
You need to log in before you can comment on or make changes to this bug.