Closed Bug 1132418 Opened 5 years ago Closed 5 years ago

[FTE] Incorrect coloured status bar and icons

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: epang, Assigned: gmarty)

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Attached image incorrect-statusbar.jpg
Some of the FTE screens are using the incorrect status bar colours.  None of the primary ones but once links are clicked. All of them should have the light status bar with the dark grey icons as seen in the other FTE screens.  I've attached an image of the screens.

1. Geolocation > About Firefox OS
a. EverythingMe - Policy
b. Firefox OS

2. Import Contacts
a. Gmail
b. Outlook
c. Facebook

3. About Firefox OS
a. Firefox OS Privacy Notice (same as 1b)
Assignee: mhenretty → gmarty
blocking-b2g: --- → 2.2?
Lets fix them
blocking-b2g: 2.2? → 2.2+
I've never worked on the status bar colour so I'm not familiar with the complex logic, but when digging into this bug, I found several open questions.

Which logic do we want here?
Do we want to propagate the theme of the main app to the popups it opened?
What if the site opened in a popup has a `theme-color` meta tag? Should we ignore it and force the parent app theme? e.g. a red theme app opens a green theme site, what colour should have the status bar?
Eric, can you clarify these points?
Flags: needinfo?(epang)
(In reply to Guillaume Marty [:gmarty] from comment #2)
> I've never worked on the status bar colour so I'm not familiar with the
> complex logic, but when digging into this bug, I found several open
> questions.
> 
> Which logic do we want here?
> Do we want to propagate the theme of the main app to the popups it opened?
> What if the site opened in a popup has a `theme-color` meta tag? Should we
> ignore it and force the parent app theme? e.g. a red theme app opens a green
> theme site, what colour should have the status bar?
> Eric, can you clarify these points?

Hey Guillaume, I talked to Michael about this and we decided that we want to keep the theme color of the originating app when opening a pop-up.

Can you flag me for ui-review when this is ready?  Thanks!
Flags: needinfo?(epang)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

Hi Eric, the patch is ready for ui-review.
I added a dev-only app to check all possible configuration. This app is made of a main page and a popup. On each page there are buttons to change the theme (1 dark and 1 light). The suggested test is to change the theme to a dark one and open the popup ; then, close the popup and do the same with the light theme. Also, changing the theme color in the popup doesn't have any effect.
Attachment #8565837 - Flags: ui-review?(epang)
Attached image 2015-02-18-12-09-11.png
Hey Guillaume, the status bar looks good now, thanks!  But I noticed an issue with the ssl lock that wasn't there before.  It's not appearing where it used too, did this patch cause this? See attached.
Flags: needinfo?(gmarty)
Thanks Eric for the review. I'll go ahead with the current patch. This visual regression is not related to this one (not sure if there's a bug opened for that).
Flags: needinfo?(gmarty)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

Hey Vivien. It looks like you did some work on the theme color. Can you have a look at this patch?
It also contains an dev app to test multiple configuration for testing the theme color.
Attachment #8565837 - Flags: review?(21)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

R+ since the regression I found was not caused by this bug.  Thanks Guillaume!
Attachment #8565837 - Flags: ui-review?(epang) → ui-review+
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

Etienne, maybe if Vivien is too busy at the moment?
Attachment #8565837 - Flags: review?(etienne)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

It's a tricky one :)
Some comments on github, feel free to ping me on IRC if you want to talk about it.
Attachment #8565837 - Flags: review?(etienne)
Attachment #8565837 - Flags: review?(21)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

I addressed your comments on Github and what we discussed offline in this PR.
Attachment #8565837 - Flags: review?(etienne)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

Made one last comment on github, but good to go :)
Attachment #8565837 - Flags: review?(etienne) → review+
Landed in https://github.com/mozilla-b2g/gaia/commit/c6492a4f9ef646b0f129db53b06e46f8470d1acf
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(gmarty)
Target Milestone: --- → 2.2 S7 (6mar)
Comment on attachment 8565837 [details] [review]
[gaia] gmarty:Bug-1132418-Incorrect-coloured-status-bar-and-icons > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): The theme colour API
[User impact] if declined: Pop ups won't have the same theme colour as their parents. That creates a confusing UX.
[Testing completed]: This patch is unit tested and there's an internal app to make manual testing easier.
[Risk to taking this patch] (and alternatives if risky): Low as unit tested
[String changes made]: None
Flags: needinfo?(gmarty)
Attachment #8565837 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8565837 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The staus bar is light grey with dark grey icons in all FTU pages.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150313010238
Gaia: eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gecko: 42afc7ef5ccb
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150313002507
Gaia: 4aefc3f6f30a40ac67fdf841b7c90cd648b85369
Gecko: 049713f3b0ed
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.