Closed Bug 1132498 Opened 5 years ago Closed 5 years ago

top-like utility for add-ons and webpages CPU and memory usage

Categories

(Toolkit :: Performance Monitoring, defect)

36 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1157009

People

(Reporter: Yoric, Assigned: shubham)

References

(Depends on 1 open bug)

Details

We need a utility that power users will be able to use to find out which add-ons/webpages are causing high CPU/jank/memory usage.

This can be built on top of about:compartments.
Hi,

I would like to work on this bug. How should I start with this bug?
This bug is quite complicated and depends on other components that have not landed yet. If you are looking for a simple bug, I believe that you should rather start by looking on http://www.joshmatthews.net/bugsahoy/
Hi,

I have already worked on the simple bugs on Bugs Ahoy. I can say I am past the beginner level bugs. I was going through the GSoC 15 Brainstorming page of Mozilla and I found this bug. The idea really impressed me as there is definitely a need for this. But I am not sure now how will the bug proceed as you said that it depends on other components which have not landed yet!
Since the bug depends on other bugs, we have decided to build prototypes for the bug. The prototype (v1) will have a sortable list listing all the add-ons/webpages with their names, time, cpow, memory. Since the values can change, the list is refreshed every 5 seconds.

Also, on clicking on any title of column, the list gets sorted according to that column. We have assumed a list of JSON objects which will have all the information about the names, time, cpow and memory usage by these items.

The prortotype v1 can be seen at http://www.cse.iitd.ac.in/~cs5110300/Dashboard/performance.html

I will soon start work on prototype v2.
Assignee: nobody → shubhamjindal18
Blake, would you be interested in co-mentoring shubham?
Flags: needinfo?(bwinton)
I do like mentoring people, but I'm a little swamped with other work right now…
What would be involved in co-mentoring?
Flags: needinfo?(bwinton)
Well, shubham is working on a few mockups/early prototypes, so if you could take a look at them when he's ready to show them, that would be great.
I could probably do that, but I think :phlsa or :maritz might be better choices…
Hi Blake,
Are you going to co-mentor me on this? I can also ask :phlsa or :maritz for this too as you suggest..:)
Flags: needinfo?(bwinton)
Hi Blake,
Are you going to co-mentor me on this? I can also ask :phlsa or :maritz for this too as you suggest..:)
I could co-mentor you.  (But I should warn you that my mentoring will largely consist of bothering :phlsa and :maritz to review your mockups.  ;)  I'm more of a prototyper than a designer.)
Flags: needinfo?(bwinton)
related/potential duplicates: bug 515352, bug 512469, bug 269685, bug 400120
OS: Mac OS X → All
Summary: top-like utility for add-ons and webpages → top-like utility for add-ons and webpages CPU and memory usage
Component: General → Performance Monitoring
Product: Firefox → Toolkit
Redesign has basically taken place as part of bug 1157009.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157009
You need to log in before you can comment on or make changes to this bug.