If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update the state of coalesced jobs to 'coalesced' rather than leaving them as 'pending/running'

RESOLVED DUPLICATE of bug 1400069

Status

Tree Management
Treeherder: Data Ingestion
P2
normal
RESOLVED DUPLICATE of bug 1400069
3 years ago
12 days ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
At present, if we find a job was coalesced into another as part of jobs ingestion, we mark the old (and no longer going to be run job) with the new jobs's guid, under 'job_coalesced_to_guid'.

However we don't update the state of the job, so it remains as 'running'.

As a result, the UI has to jump through hoops in several places - ie "if job_coalesced_to_guid set, pretend the state was coalesced, otherwise use the actual value of 'state'".

We should just update the value here:
https://github.com/mozilla/treeherder-service/blob/eabe3a47de94d5debb009bfd5973b4779e1bbbb0/treeherder/etl/buildapi.py#L84

And then we can replace most references to job_coalesced_to_guid in the UI, with things like |state === 'coalesced'|.
(Reporter)

Comment 1

3 years ago
As Cameron correctly pointed out, coalesced jobs should currently be being left in the pending state, however I've found some that are running, eg:
https://treeherder.mozilla.org/api/project/mozilla-inbound/jobs/6567137/

{
...
	"result": "unknown",
	"id": 6567137,
...
	"job_guid": "ba1d4b24b181e59c1de8a80910b5126130973779",
	"artifacts": [{
		"resource_uri": "/api/project/mozilla-inbound/artifact/34383848/",
		"type": "json",
		"id": 34383848,
		"name": "buildapi_pending"
	},
	{
		"resource_uri": "/api/project/mozilla-inbound/artifact/34383849/",
		"type": "json",
		"id": 34383849,
		"name": "buildapi"
	},
	{
		"resource_uri": "/api/project/mozilla-inbound/artifact/34388095/",
		"type": "json",
		"id": 34388095,
		"name": "buildapi_running"
	}],
...
	"state": "running",
	"running_eta": 3871,
	"pending_eta": 136,
	"end_timestamp": 0,
...
}
Summary: Update the state of coalesced jobs to 'coalesced' rather than leaving them as 'running' → Update the state of coalesced jobs to 'coalesced' rather than leaving them as 'pending/running'
(Reporter)

Updated

3 years ago
Priority: P2 → P4
(Reporter)

Comment 2

3 years ago
Fixing this now would avoid setting an unfortunate broken precedent, re bug 1161128 etc.
Priority: P4 → P2
(Reporter)

Comment 3

3 years ago
Fixing this would have avoided the issue in bug 1163496.

Relevant code:
https://github.com/mozilla/treeherder/blob/54727c2994d9f937bd6297dadd000580bfcfc891/treeherder/model/derived/jobs.py#L1339-L1346
https://github.com/mozilla/treeherder/blob/d7a2544aed5a31e4dc493473bb221de5be441b7e/treeherder/model/sql/jobs.json#L297-L303

I'm pretty sure the comment 1 case (state===running) was another symptom of bug 1093743, so can be ignored for now.
(Reporter)

Comment 4

12 days ago
Fixed as part of bug 1400069 :-)
Status: NEW → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1400069
You need to log in before you can comment on or make changes to this bug.