Closed Bug 1132571 Opened 5 years ago Closed 5 years ago

[RTL][Cost Control] [Usage] - The Mobile usage per app blue 'progress bar' / usage indicator is not RTL aligned.

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jmitchell, Assigned: autra)

References

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Attached image 2015-02-12-11-01-04.png
Description:
 In the Usage app, mobile usage is tracked by individual app through a listing of apps and blue bars indicating the percentage of total mobile usage. These bars are no properly represented in RTL where they should read Right-To-Left with the blue 'used' portion on the right side and the white portion on the left side.

Repro Steps: (In an RTL language)
1) Update a Flame to 20150212010213
2) Enable Data and disable wifi
3) Launch Usage app and complete FTE
4) Use some Mobile data to propigate Mobile usage per app data
5) Return to Usage app and observe Usage: Mobile usage per app section


Actual:
Mobile usage per app is not RTL aligned

Expected:
Mobile usage per app bars will be RTL aligned

Environmental Variables:
Device: Flame 3.0
Build ID: 20150212010213
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 3094601af679
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: screenshot

-----------------------------------------------------------------------------------

This also occurs in 2.2 

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150212002504
Gaia: 791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gecko: 5dec207fcbeb
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Summary: [Cost Control] [Usage] - The Mobile usage per app blue 'progress bar' / usage indicator is not RTL aligned. → [RTL][Cost Control] [Usage] - The Mobile usage per app blue 'progress bar' / usage indicator is not RTL aligned.
triage: P2 & targeted for 2.2. We should fix this one.
feature-b2g: --- → 2.2+
Priority: -- → P2
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Assignee: nobody → augustin.trancart
Comment on attachment 8565473 [details] [review]
[gaia] autra:bug-1132571 > mozilla-b2g:master

Hey Salvador!

Just a quick css fix for this one. Changing the original float from left to inherit also works. I preferred to explicitly change in rtl case though...
Attachment #8565473 - Flags: review?(salva)
Comment on attachment 8565473 [details] [review]
[gaia] autra:bug-1132571 > mozilla-b2g:master

LGTM, thank you!
Attachment #8565473 - Flags: review?(salva) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8565473 [details] [review]
[gaia] autra:bug-1132571 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): lack of RTL support
[User impact] if declined: empty/full part of the bar are reversed for rtl users.
[Testing completed]: on flame 2.2
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: none.
Attachment #8565473 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8565473 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly  Flame KK 3.0 and 2.2 builds.

Actual Results: The Progress bars are RTL.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150223010224
Gaia: a6881205deae450757a8d1e1ed65e5e5be0ec633
Gecko: 86d2bb8bb1c9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150223002503
Gaia: 389542b71c89253c0d176d3b0bfb54e275c19bf1
Gecko: 9fd3441c8983
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
You need to log in before you can comment on or make changes to this bug.