Trouble compiling Mozilla 0.9.6 using Sun Workshop 6

RESOLVED FIXED in mozilla0.9.6

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: slarti-mox, Assigned: scc)

Tracking

Trunk
mozilla0.9.6
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
My system:

relativity:/local/src/mozilla# cc -V       
cc: Sun WorkShop 6 update 1 C 5.2 2000/09/11

relativity:/local/src/mozilla# ./configure --with-system-jpeg --with-system-png
--with-system-zlib --disable-mailnews --enable-crypto --disable-debug
--disable-logging --with-libIDL-prefix=/home/slarti/.local-SunOS/

relativity:/local/src/mozilla# uname -a
SunOS relativity 5.8 Generic_108528-08 sun4u sparc SUNW,Ultra-5_10

I've applied a recent Sun-provided Sol8 Recommended patch set, as well as both
patch lists specified by mozilla.org for using Mozilla and by Sun for using
Netscape 6. I've tried doing this build using gcc 2.95.2 and 3.0.2 before, and
while it builds, running it gives an immediate segfault. So, I'm trying with
Sun's cc. libIDL is mozilla's, not ORBit. Building using gmake.

The problem:

relativity:/local/src/mozilla# gmake
[bunch of compile gets done, then:]
Building deps for nsAString.cpp
CC -o nsAString.o -c -DOSTYPE=\"SunOS5\" -DOSARCH=\"SunOS\" -DOJI -D_IMPL_NS_COM
-D_IMPL_NS_BASE  -I../../dist/include/xpcom -I../../dist/include/string
-I../../dist/include -I/local/src/mozilla/dist/include/nspr     
-I/usr/openwin/include   -KPIC  -I/usr/openwin/include -mt  -DNDEBUG -DTRIMMED
-I/usr/openwin/include -DMOZILLA_CLIENT -DBROKEN_QSORT=1
-DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1
-DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1
-DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1
-DHAVE_X11_XKBLIB_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1
-DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1
-DHAVE_LIBSOCKET=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1
-DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_LOCALTIME_R=1
-DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_NL_LANGINFO=1
-DHAVE_STRTOK_R=1 -DHAVE_IOS_BINARY=1 -DHAVE_CPP_EXPLICIT=1
-DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SPECIALIZE_TEMPLATE_SYNTAX=1
-DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHANGING_USING=1
-DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1
-DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1
-DHAVE_CPP_DYNAMIC_CAST_TO_VOID_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1
-DHAVE_I18N_LC_MESSAGES=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DMOZ_WIDGET_GTK=1
-DMOZ_ENABLE_XREMOTE=1 -DMOZ_X11=1 -DIBMBIDI=1 -DACCESSIBILITY=1
-DNS_DISABLE_LOGGING=1 -DMOZ_USER_DIR=\".mozilla\" -DMOZ_XUL=1 -DINCLUDE_XUL=1
-DNS_MT_SUPPORTED=1 -DUSE_IMG2=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1
-DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1  nsAString.cpp
"../../dist/include/string/nsAlgorithm.h", line 90: Error: Formal argument iter
of type unsigned short**& in call to static nsCharSinkTraits<unsigned
short*>::write(unsigned short**&, unsigned short*const*, unsigned) is being
passed unsigned short*.
"nsAString.cpp", line 276:     Where: While instantiating
"copy_string<nsReadingIterator<unsigned short>, unsigned
short*>(nsReadingIterator<unsigned short>&, const nsReadingIterator<unsigned
short>&, unsigned short*&)".
"nsAString.cpp", line 276:     Where: Instantiated from non-template code.
"../../dist/include/string/nsAlgorithm.h", line 90: Error: Formal argument s of
type unsigned short*const* in call to static nsCharSinkTraits<unsigned
short*>::write(unsigned short**&, unsigned short*const*, unsigned) is being
passed const unsigned short*.
"nsAString.cpp", line 276:     Where: While instantiating
"copy_string<nsReadingIterator<unsigned short>, unsigned
short*>(nsReadingIterator<unsigned short>&, const nsReadingIterator<unsigned
short>&, unsigned short*&)".
"nsAString.cpp", line 276:     Where: Instantiated from non-template code.
2 Error(s) detected.
gmake[2]: *** [nsAString.o] Error 2
gmake[2]: Leaving directory `/local/src/mozilla/string/src'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/local/src/mozilla/string'
gmake: *** [install] Error 2

Comment 1

17 years ago
You may need some compiler patches (see http://access1.sun.com/forte/). I am
running Sun Workshop 6 Update _2_ and Mozilla.org runns a WS6U2 tinderbox
machine ("nebiros", see
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey-Ports).

The follwing works for me:
% cc -V
cc: Sun WorkShop 6 update 2 C 5.3 2001/05/15
usage: cc [ options] files.  Use 'cc -flags' for details
% CC -V
CC: Sun WorkShop 6 update 2 C++ 5.3 2001/05/15
(Reporter)

Comment 2

17 years ago
OK, yeah, upgrading to Forte 6U2 allowed me to build the thing without any
problems. Well, no problems except that it segfaults when I try to run it. But
that's a separate issue from this one. Looks like I'll mark the bug fixed, try
compiling with other options (particularly activating debugging and logging),
and file a different bug if it still continues segfaulting.

Thanks, Roland!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9.6

Comment 3

17 years ago
Please CC: me to the new bug, please.

And "-fast" does not work because this macro ("-fast" is a macro, see cc(1) !!)
uses some flags which are incompatible to some code.
Maximum optimisation working with Sun Workshop 6 Update 2 + product patches:
--enable-optimize="-dalign -xO4 -xtarget=generic -xbuiltin=%all -xlibmil"

----

BTW: Wanna try --enable-toolkit=xlib ? This flags uses an alternative
widget/rendering module which does not require GDK/GTK+ libraries, even if you
build a 64bit Zilla ...
You need to log in before you can comment on or make changes to this bug.