[RTL][Homescreen]The select smart collections view is displayed as black.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Homescreen
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

Attachments

(1 attachment)

3.22 MB, video/mp4
Details
(Reporter)

Description

3 years ago
Created attachment 8564022 [details]
video.MP4

[1.Description]:
[RTL][Homescreen]When you go to select smart collections view, the items in select smart collections view are not shown till you tap on the screen.
See attachment:video.MP4

[2.Testing Steps]: 
1. Set your phone language to Arabic. 
2. Long press the blank area on homescreen. 
3. Select "Add Smart Collections". 
4. Observe the select smart collections view.
5. Tap the black page.
**The items in select smart collections view will show up.

[3.Expected Result]: 
4. The items in select smart collections view should be displayed normally.

[4.Actual Result]: 
4. The select smart collections view is displayed as black.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150212002504
Gaia Revision          791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gaia Date              2015-02-11 19:31:02
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5dec207fcbeb
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150212.042208
Firmware Date          Thu Feb 12 04:22:18 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15437
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
I'm unable to reproduce on either master or 2.2 with today's builds. Can you retry to see if this is still an issue?
Flags: needinfo?(lulu.tian)
Keywords: qawanted
Unable to reproduce on today's Flame 2.2 and 3.0

With language set to Arabic, long pressing on homescreen and selecting add new smart collections shows list of available collections correctly. No blank black screen is visible at any time.

Device: Flame 2.2
Build ID: 20150213002503
Gaia: ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko: d04b78eeb536
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
BuildID: 20150213010213
Gaia: 2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gecko: 2f5c5ec1a24b
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: bzumwalt
Closing this as worksforme. Please feel free to reopen if the issue is encountered again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

3 years ago
Unable to reproduce on today's Flame 2.2, with language set to Arabic, long pressing on homescreen and select add new smart collections shows list of available collections correctly. No blank black screen is visible at any time. Clear the needinfo.
If anyone can repro it, reopen again.

Flame 2.2 build:
Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lulu.tian)
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.