pdf.js: page numbering in PDF file is not correct

RESOLVED FIXED in Firefox 48

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: liebundartig, Unassigned)

Tracking

35 Branch
Firefox 48
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7069)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8564026 [details]
ev-quarterly-2014_Q3.pdf

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222326

Steps to reproduce:

Open
https://ev.kde.org/reports/ev-quarterly-2014_Q3.pdf
(see attached file)
with internal PDF viewer of Firefox 35.0.1 (pdf.js) on Mac OS X 10.10 as well as Lubuntu 14.04


Actual results:

The page numbering (on page 2 of 9) starts with "5" instead of "2".
The page numbering goes on:
6
7
8
9
;
:


Expected results:

The page numbering on page 2 of 9 should start with "2" and go on: 3,4,5,6,7,8


Evince 3.10.3 on Lubuntu 14.04 and Preview on Mac OS X display it this way.


Albert Astals Cid (one of the creators of the PDF file) said the file was created using Scribus. His guess is that either the wrong font or the wrong font charmap is used in pdf.js.

The charmap seems to be a good start, if you compare the actual result and the ASCII table: http://www.asciitable.com/
(Reporter)

Comment 1

3 years ago
I mixed up the end of the actual page numbering. It is ":" followed by ";"

Furthermore, I installed the Development Version of pdf.js (PDF Viewer 1.0.1143) as suggested by
https://github.com/mozilla/pdf.js/
and restarted Firefox. The problem is present in this version as well.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
OS: Linux → All
Created attachment 8564602 [details]
Reduced test-case

Updated

3 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7069
Depends on: 1256037
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
You need to log in before you can comment on or make changes to this bug.